Scrivener/Scapple for Windows Activation under Wine

Wine 4.0.2 comes with Mono, which does not allow the license activation to
work. Mono apparently has problems with TLS 1.2, which is required for the
license activation component to connect to the server.
The following steps have resolved the problem for some users:

  1. Open the terminal window (Ctrl+Alt+T)
  2. wine uninstaller
  3. Add/remove programs window will open. Uninstall Mono and close the window
  4. sudo apt-get install winetricks
  5. winetricks --force dotnet452
    Installing a newer dotnet version is a good option and even recommended.

When you start Scrivener or Scapple after this, the license activation
component should work.

Can we sticky this? :slight_smile:

Good idea!

It worked for me! Thanks for sharing the good tip. I thought I could never get to the end of my story that is maybe too long to tell :slight_smile:. This trick saved me many headaches. Thank you so much!

Excellent. Thank you. Worked for me on Manjaro with the appropriate pacman commands.

Having tried the method described above and finding it did not work for me, I started searching for a possible solution on I ended up coming up with a simple process that was successful and repeatable when used again on a freshly set up laptop. In order to avoid the potential for interfering with other software I had installed under Wine, I did all this in a new Wine prefix.

I tried to create a script for this but discovered that it was executing steps before prior steps had completed. I therefore suggest each command is run separately once the preceding step has fully finished. Those steps are:

env WINEARCH=win64
env WINEPREFIX=$HOME/wine_scrivener wineboot --init
env WINEPREFIX=$HOME/wine_scrivener winetricks dotnet40 corefonts
env WINEPREFIX=$HOME/wine_scrivener winetricks win7
env WINEPREFIX=$HOME/wine_scrivener winetricks dotnet462
env WINEPREFIX=$HOME/wine_scrivener wine Scrivener-1.9.15.exe

The same process also worked for the latest V3 beta.

Just for clarity; Scrivener itself worked just fine using the originally posted procedure but the new Paddle activation didn’t.

I’ve used Scrivener on Mac from the beginning, and I’ve also been running the Windows 3 betas under Wine since Linux support was discontinued. There were always minor issues with this but in general the betas were good enough to do useful work, and I was able to go back and forth between Linux and Mac fairly smoothly. Now though, with Beta 30, Scrivener will not run under Wine with my setup. I’m running Ubuntu bionic (18.0.4 LTS). I’ve upgraded Wine to 4.0.3 and, following a tip on this forum, I updated dotnet to 4.5.2.

I note that the Beta 30 release states dotnet 4.6.2 is required. I have not been able to install that on my LTS version. For what it’s worth, Scapple runs fine, as do a variety of other Windows programs which I also run on my Mac, such as Aeon Timeline 2 and Postbox.

I do realize Linux is no longer supported, but I have been consistently impressed by how well the Scrivener 3.0 betas have run under Wine. In fact, I wrote a very popular Medium post about this: … 35c710e413.

But now I’m at a standstill with Scrivener on Ubuntu. I’m not sure why Beta 30 would up the dotnet requirements to the point of breaking compatibility, if indeed that’s what happened. Needless to say, though, after so many successful beta versions this is a huge disappointment.

If anyone has any suggestions on how to get this beta working under Wine, I’d be grateful. Meanwhile, for the developers, I’m attaching the backtrace which details the unhandled exception and other errors.

Many thanks.
backtrace.txt (18.5 KB)

Are you using Winetricks? That should help you get 4.6.2 (or later) installed, ass mentioned just a few posts up-thread.

I had the same issue initially with Linux Mint but it worked perfectly when I started with a new Wine prefix. Since writing my earlier post in this topic, I’ve been able to reproduce my success on other distros at work, where each of us in the IT department have our own Linux preferences.

I used winetricks to install 4.5.2; it fails with 4.6.2.

I’ll give this a try; thanks.

Unfortunately, I’m getting the same result using a new [Windows 7] prefix. Are there any particular configuration settings I might be missing? I suspect the fact I’m not running dotnet 4.6.2 may be at the root of the problem here, I’m wondering what changed between beta 29 and beta 30 to necessitate breaking Wine compatibility.

64 or 32 bit? I don’t think dotnet 4.6.2 will install in 32 bit.

I was out of ideas so I thought I’d redo this process a bunch of times to see if I could get it to fail and eventualy it did. On the failed run I noticed that switched the environment to Server 2003 for dotnet 4.5 but failed to switch it back. I also found that after the point of failure, by re-running “env WINEPREFIX=$HOME/wine_scrivener winetricks win7” and then rerunning “env WINEPREFIX=$HOME/wine_scrivener winetricks dotnet462” the install was successful.

Good luck.

It’s supposed to be compatible with 7-10 x86 or x64 according to Microsoft.

Is there any way to clear the cached downloads and try it again with a freshly downloaded copy of the installer? I’m not familiar with Winetricks…

That may well be the case on Windows but that doesn’t mean it will on Wine.

On my machine I found the cache at ~/.cache/winetricks, which I would expect to be pretty consistent across distros.

Another dumb question – does the Windows 7 prefix have SP1 installed or is it stock Win7? Apparently it is a known issue that 4.6.2 will not install without SP1.

On the contrary, I’d call that an excellent question, for which I don’t have an answer, nor can I think of a ready way to find out. If I do find out I’ll post again.

Thanks for this—it seems very promising. However, when I ran the second env command above, I got the dreaded “dotnet462 conflicts with dotnet40, which is already installed.” Winecfg doesn’t seem to be able to get rid of dotnet 40. I’m beginning to think I may need to remove Wine altogether and start from scratch.

I believe iit’s the stock win7—didn’t see an option for SP1. Is there a way to add this with winecfg? Thanks for the clue, BTW.