Scrivener Scratchpad Uses Invalid Linux Pathname

The Beta 110 on Windows creates rtf files within the Scrivener Scratchpad directory. The Linux version of this Beta can neither read nor write files in this directory, because it is using a back-slash “” as a file separator between the target directory and the scratchpad’s rtf file name. The Linux version leaves a zero-length file “Scrivener Scratchpad\untitled note” in the same directory that holds the “Scrivener Scratchpad” directory; note the presence of the backslash in the file name string. Though Linux can see the rtf files that the Windows version put there (they appear in the scratchpad file list), it cannot open them. (I’m using Dropbox to transfer files between systems, but I’m not running Scrivener at the same time on the two systems).

Ubuntu 10.05 and Windows 8 Consumer Preview in a virtual machine.

Thanks for your time.

Nathan Zalman

Thanks, logged it.

Is there an easy work around for this, while it is being fixed for the next version? Currently scratchpad does not work for me in Linux.
(Scrivener 1.1.0 beta 32 on Mint 11 Katya 64 bit Linux running on a Dell Latitude e4300 laptop)

Just curious: I assume no reply means no workarounds for this issue yet. The scratchpad feature can’t be used on Linux, right?
Thanks in advance for your reply and sorry if I should have been able to find an answer elsewhere (I did look).

I just tried it and it works for me. The note appears in the “Scrivener Scratchpad” directory in my home directory. I can edit it, change the title and save it just fine.

Ah. OK. Thanks very much for the reply. Great to know that it should work. Must be something wrong with my setup then.

My symptoms are:
Scratchpad window comes up, but can’t be moved (which is a problem when I’m using two monitors and it comes up off-screen, as it is doing at present), isn’t transparent, and floats above all other windows. It seems to be missing a window title bar, borders, etc. (Perhaps why it can’t be dragged?)
The split window shows the two files in the “~/Scrivener ScratchPad/” directory (“untitled note” and “untitled note_1.rtf”) but doesn’t open them in an .rtf editor (or anything else) when clicked. I can go into my file manager and double click on the files and get them to open in Open Office, but I don’t think that is the way scratchpad is supposed to work, is it? Certainly not the elegant way my Mac version works. The editing in Open Office then shows up in the scratchpad window and can be selected sent or appended to files in the binder; but it still can’t be edited in the scratchpad window. Very odd.

I’d be very grateful for any ideas or suggestions you have. (Also, should I open this as a new issue?)
Thanks very much in advance.

Using Scrivener (32 bit), computer and OS as below.

Processor 2x Intel® Core™2 Duo CPU P9400 @ 2.40GHz
Memory 4008MB (2102MB used)
Operating System Linux Mint 11 Katya
Kernel Linux 2.6.38-8-generic (x86_64)
Compiled #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011
C Library Unknown
Default C Compiler GNU C Compiler version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Distribution Linux Mint 11 Katya

I have the same problem Ian describes.
No text can be entered in the scratchpad.

The global shortcut doesn’t work.

I’m using KDE with awesome window manager.

Yep, having that issue as well. (You can guess how often I use the scratch pad.)

Does anyone know whether scratchpad now works with the latest released Scrivener ( I’m using Scrivener on this computer for work at the moment so reluctant to upgrade until I’ve tried it on my non-work computer for a few days to check things run ok. (And I’ve a deadline so it might be a few days before I get to that.) But I’d love to be able to use scratchpad on the Linux scrivener. It is something I’ve really missed!
(Mint Linux Debian UP6)

PS Technatica, Did you have to install a separate rtf editor to make scratchpad work? I assumed it should just work using whatever rtf editor scratchpad uses to edit its other files.

Same problem with Linux beta –
Scratchpad window is frozen, cannot be moved;
Prior entries and text displayed, but cannot be edited.

Running #! Linux (Debian)

Yes. I just installed the latest Beta too. Same (lack of) behaviour remains:
The scratchpad opens. Shows a list of files in the scratchpad folder, which floats above all other windows. Can click on those files and the contents are displayed. But all typing goes straight to the Scrivener window and not to the scratchpad window/files so can’t be edited in Scrivener. And attempting to append their contents to a scrivener file doesn’t work. Those scratchpad files can be opened separately using a filemanager and a text editor but the integration with scratchpad basically just doesn’t work–on my machine.

Yet if I understand earlier posts apparently some people’s scratchpad is functioning correctly?

Oh, and a minor point given that the core functionality of scratchpad isn’t working, but the shortcut key ctrl-alt-shift-P doesn’t work to open the scratchpad window. I had to open it from the menus.

All this is running on an aging Acer Aspire One 150 netbook 32-bit Mint LMDE Upgrade Pack 6. (Though as you’ll see in my earlier posting my 64-bit machine, which hasn’t yet got the latest upgrade was showing the same symptoms with the last beta but one.)

Thanks very much to the developers and package maintainers and everyone else producing this great piece of software. I enjoy using the bits that work and very much look forward to it catching up with the Mac functionality little by little.

All the best,

This is something else that does not work for me, same lack of behaviour as idc has.

I can however open it with the keyboard shortcut CTL+SHIFT+/.

I am still unable to thank anyone for producing this software as there is virtually nothing that works for me. I have wasted a week so far and have not managed to import one word yet, let alone do anything constructive.

I can open the Scratchpad from the menu, create empty files, and see the contents of files I created when I edit them externally, but it sits in the top-left corner as an non-movable window and can’t be edited or copy-pasted from. However, sending text to Scrivener from the Scratchpad using the button does appear to work, though I initially thought it didn’t – either it was hiding down at the bottom of the document or it miraculously appeared in the process of syncing to Dropbox and switching to a different (Windows) computer.

(Linux Mint 13 32-bit; Beta; everything else seems to be working fine for me apart from my idiosyncratic issue with the full-screen background transparency.)

I found that if I click on the “Fist” icon at the bottom of the scratchpad window, which is apparently the “Grab an area with the mouse” function, then drag down the lower edge of the window that is mostly hidden under the scratchpad window, until I can expose the menu buttons … I click the “cancel” button and suddenly I’m able to select entries and edit in the text panes. But the pane is frozen; it cannot be dragged.

Each time the scratchpad window comes up, the same “fix” must be used. I can also edit & revise the .rtf files in the external scratchpad files folder using LO “Writer” or Calligra Words. “Ted” does not display the .rtf file properly, scrambling the characters.

YIKES! … while typing this entry in IceWeasel, in an entirely different screen pane, the Scrivener scratchpad pane appeared over the top of my web browser and is locked in place! I can drag the browser window about, but the scratchpad window is a fixed, opaque entity. (Scrivener is running in a different virtual window, one of four on my desktop)

I’ve just clicked the “fist” icon, which activated the secondary ‘grab’ window; dragged the lower edge down to expose the control buttons, and clicked ‘cancel.’ Then I clicked “OK” in the scratchpad window, and it has closed and disappeared. I’ll assume it’s gone back home to the Scrivener screen.

I’ve never had part of an app jump from one screen to land on top of a completely different app before … ???

It appears there is something about that “Grab” screen function that is reacting wildly ??

Running Scrivener linux version
Antix (Debian) Linux

Graybyrd’s fix doesn’t work for me – the Scratchpad pane doesn’t want to take the typing focus no matter what I do. (It seems to stay with whichever window was active last, whether that’s the main Scrivener window or my web browser.) I did notice that the unmoveable Scratchpad window appears in all four workspaces, so apparently it isn’t communicating properly with the window manager.

(I get the same behaviour in my Ubuntu 11.10 setup under VMWare as on the machine with Mint 13 MATE.)

I can confirm Graybyrd’s observation with the latest beta. Simply clicking the fist and then hitting cancel enabled me to create new notes, rename them, and edit/add text. I still can’t drag or resize the window.

The information below may be completely irrelevant to this issue and may not be an issue at all. It’s all I’ve got to offer. From terminal…

64-bit Ubuntu 12.10 w/ KDE

Hmm. I haven’t been able to edit the text using Graybyrds ‘workaround’, though I am able to select text that was already entered and send it to Scrivener.
Thanks very much to those working on this problem. It would be really nice to see the scratchpad working. (I’ll keep looking in here every once in a while.)

I’m seeing this problem (scratchpad cannot edit texts, the window isn’t movable, any keystrokes are passed straight through to the main Scrivener window) in the latest beta ( 32 bit) on Bodhi 3 RC1 based on Ubuntu 14.04, using Enlightenment 19 as the desktop.

From the fact there have no posts on this subject for a long while, I assume the bug has been fixed, yet it’s still not working for me. For those who have it working, was there anything special you did?

Not fixed for me I’m afraid.
I haven’t checked whether I’ve got the latest Linux version though. Will have to do so when I’m next on my Mint Linux laptop.
All the best,

I have the same problem. I cannot put any text into Scratchpad notes or rename the notes, including after applying the fist-cancel workaround.

Ubuntu 14.10, Scrivener 32-bit.