Section headings when formatting for PDF

Trying to create a print ready PDF.

Okay, so I have a prologue, epilogue and back matter that have titles.

I want the titles to be formatted the same as chapter numbers, but when I do so there’s no line between the heading and the text below it. This looks kinda funky and I want to insert some space, same as with chapter numbers.

I managed after three hours of considering uninstalling Scrivener to get this to work, and ran the print proof…but somehow doing so had caused all apostrophes and quotes to vanish from the effected sections.

Anyone know how to do this without that happening? It’s driving me to the point of wishing I had $250 spare for Vellum…

Assuming you’re using the Mac version 3, then you do this using different Section Types allocated to the prologue, epilogue and back matter, then allocate them the appropriate Section Layout in the compiler, making sure that you choose one which has the Chapter Title, rather than the Chapter Number. If you’re using one of the default compilation targets, then you really shouldn’t have to do much more than that — it’s one of the basic features of compilation.

Unfortunately, it’s impossible to tell what’s going wrong in your project without a few more details – could you tell us the steps you took to get to where you are? ie. Which compilation target you’ve chosen, which Section Layouts you’ve allocated to the epilogue etc, whether you’re using the Titles from the Binder, or adding them in the text itself and so on. This will help us to help you get back on track.

[BTW, if the discussion about Section Types and Layouts is new to you, then it’s probably worth your looking at the inbuilt Tutorial first to see what we’re talking about: any help we give you will be based on them and it’s important to understand how they work to get the right answer.]

Titled chapter has number and subheading. I don’t want to number these sections.

I’m not adding the titles manually, so yeah, they’re from the Binder. It automatically adds them as italicized headers, but I don’t want that, I want a uniform look, so I change the style from that to the one for chapter numbers, and all spacing vanishes.

Meaning that instead of.

1

Text text

I get

Prologue
Text text

I’m compiling to pdf.

I’m using Section. That seems to be the only way to get the headers added without also getting numbers. I think I do understand how they work, I just can’t get them to do what I actually want.

Have you done the interactive tutorial?

OK, it sounds like that you would benefit from doing the Tutorial, because that will explain how it all hangs together better than I can in a quick post.

Briefly, I’ve set up a very quick demo project to do what you want: it’s based on the Novel template and the PDF compilation target with Default chosen in the sidebar. This is for simplicity — the steps you take are basically the same whichever template you use.

What you’re trying to do is:

  1. In the Editor you say ‘This document is of this type’ — you allocate it a Section Type.

  2. In Compilation, you say ‘I want this type (Section Type) of document to look like this’ (Section Layout).

In your case it looks like you have three different types of document (Section Types): 1. Chapters, 2. Scenes and 3. sections such as the Prologue and the Epilogue, which because you want them to look the same, can share the same Section Type.

Right, in the binder, select both the Prologue and the Epilogue, right click and choose a Section Type for them. ‘Section’ looks good enough in this simple project— it really doesn’t matter what the name is as it’s only a placeholder.

Normally, Chapters and Scenes are given appropriate Section Types anyway by default: just make sure that they each have the right one and that they’re different from the one you give the Prologue and Epilogue. If not, give then Chapter and Scene respectively (again the actual names don’t matter). Now select the Manuscript/Draft folder and show it in outline mode (cmd-3) and make sure the Section Type column is visible. You should see something like this:

Now compile the project (cmd-alt-e) and choose Compile for PDF and the Default format. Click the Assign Section Layouts button and you’ll see something like this:

You see how the Section Types you allocated are on the left hand side. Click on ‘Section’ (i.e. your prologue and epilogue) and then scroll through the list on the right until you get to the Section Layout that you want to apply. In your case it sound like you want the one called New Page Heading and Text. Click on it.

Then click on the Chapter type and choose the layout Chapter Number, like so:

You can see the similarities and the differences between the two Section Layouts: they both have large bold centred heading — the difference is that one shows just the number and the other just the title.

The other difference is that the Chapter Number layout only shows the heading – there’s no text beneath it — while the New Page Heading and Text layout obviously shows the text. Why? Because in your Binder, the text for the prologue and epilogue is provided within that document itself, but for Chapters, the text comes from separate sub-documents — the scenes.

So, the final thing you have to do is allocate a Section Layout to the Scene type — and you probably want ‘Text Section’, which doesn’t have any heading at all.

Once you’ve done that, you can press OK and then compile to test the result. I’ve done it and it gives the result you want: prologue and epilogue look the same as Chapters, except that one uses Title and the other Number. The gap between heading and text is identical. (I can’t show you the pdf because you can only include 3 screenshots on the forum).

If for any reason, you’re not happy with the layouts chosen, then try another of the built in ones. If they’re not right, then you can duplicate and edit the Default format and then edit or create your own layouts. But for many simple cases, the defaults are close enough and you may not have to do this at all.

That’s a very quick run through and of course it can get more complicated / flexible than this, which is why it’s important to read the Tutorial. And of course your document structure won’t be exactly the same as the one I’ve used here, but I hope it explains the process enough to get you started and that you find it useful.

I have read the tutorial.

And I’ve done everything said there. Section is set to “Titled Section.” The issue is that no force I can bring to bear will insert any space between the Section Title and the text below it.

There is no “new page heading with text” section layout frowns at it. There is Section with Sub-Heading. This demonstrates the same behavior, so switching to it won’t help.

I tried going to new page and adding the title to that. Same behavior.

Basically, it is defaulting to a smaller font (Heading2) and when I try to change it to Title, it doesn’t move the text down so the space between them vanishes.

I think the confusion might be that I’m trying to create a pdf of the 6 x 9 paperback format (or rather, an edited version of it). That format doesn’t have new page heading with text as an option.

All I want is for the text not to be jammed up against the header.

You duplicate one of the compile formats that comes with Scrivener. Then you set up the section types in the project and corresponding format types in Compile. Then simply format the compile format, each one of them, using the format screen in compile.

OK – that’s why I needed to know which compile formats you were using: they don’t all have the same layouts.

No problem, what you have to do now is simply amend one of the existing ones to fit your needs.

Here’s how I’d do it. First duplicate, edit and rename the Paperback 6x9 format and in the box which appears, the Section Layouts panel will already be highlighted.

Look down the list for the Layout that you want to use for your Chapter type. Based on your description, I assume it’s Chapter Heading. The dummy box contains just the number 1 – as the text for the chapter is being delivered by the Scene type. (I assume – you haven’t really said exactly, but bear with me for a moment).

But if you look further down, the layout Chapter actually shows you both the number and the text – and this is actually closer to how you want the Prologue etc to look. The only difference is that you want to change the chapter number for the title.

So we’re going to amend (or duplicate) the Chapter layout instead. Select the Chapter layout and press the + button at the top right – rename the new layout to Prologue and make sure it’s still selected.

First, click on the number in the dummy text box and you’ll see that the format buttons become available – you can change the font / size / alignment etc of the number or heading here, if you want to.

Next click on Title Options. You’ll see that <$n><$rst_scene> is in the Title Prefix box, which is what is providing the Chapter Number. Delete the entire line and replace it with <$title> (you can change the case of the title by using the dropdown) then click back on the formatting tab… You should see that the number 1 has been replaced by the word Title.

Click save, then select your new edited compile format and go to Assign Section Layouts as before and marry your section types with the desired layouts — but this time you’ll see that your new Section Layout (Prologue) is available and it’s identical to your Chapters, apart from having the title instead of the number. Assign it to the Section type.

Finally, you can compile. This is what I get:

It sounds a lot, but once you’ve done it once it’s actually quick to do in practice. Hope this helps.

Success! Thank you! (And now I never have to do it again because I saved it as a global format :wink:).

You’re very welcome — glad it helped!