Setting up Kindle eBook


I am having the same problem. The compile feature is starting at Chapter Two for a blank page. I have completed text tidying and removed any page spacing, so I am not sure where the page is coming from. The instructions above seem to be for an older version of Scrivener.

In addition, I am trying to add the front cover art for my ebook and I have put it into the document under ebook, but I still get the generic cover when it opens in Kindle. I have tried both a jpeg and a pdf file and neither have worked.

Any help would be great.

Thank you.

Unfortunately it is difficult to say without more information on how you’ve set things up. It’s unclear what you mean by page spacing, for instance, but it would also help to know if you started with a built-in project template (like “Novel”), what compile format you are using, and what the layout of your binder looks like, for starters.

What is “the document under ebook” here, is that referring to something in the binder you’ve set up? The important setting here is in the Compile overview pane itself. On the right-hand side is a tab for setting up the cover. You can select your graphic directly with that tool.

Do also note that if things are set up right, and by opening the .mobi file in Kindle you mean loading it into the macOS reader software, it isn’t really a development tool. It caches cover page thumbnails for speed, seeing as how they don’t really change from one day to the next. You should use Kindle Previewer, which is designed for content developers.

Moderator Note: split from an older thread, as there will be little common ground between what one would have done back then, and what one does now.