[SOLUTIONS] Paddle License engine fails in Wine

So upgrading to Scriv 3 today and got the free coupon to upgrade for free – but the Paddle licensing registration failed, N o idea what to do now.


Not ideal, but since they don’t officially support Linux, do you have a PC you could install it on, activate your license, and then download it on your Linux machine once it is registered?

I could borrow a laptop for that, but I don’t understand what that would do. Why would that work?

ooooooohhhhh I figured it out.

If anyone has this happen to them after they get the coupon code but it won’t proceed after you press the “Buy” button, just copy the coupon code and go to the purchase page as if you were going to buy a new copy of Scrivener 3 for Windows. Enter the code there and it will email you the new license code. The coupon code is NOT the license code!

Perhaps my Wine doesn’t have Internet Explorer installed, so couldn’t bring up the purchase page from the Scrivener registration window.

Seemed to take a while for the server to be updated with the new code, so activation failed when I tried it immediately but succeeded when I tried it about 15 minutes later.

Confirming that Scrivener 3 with Paddle works in wine then?

We ran into some issues getting the store panel to come up in internal testing, as some of us use Wine and CrossOver (based on Wine). It does indeed seem to be a dependency upon IE that is at the root of the problem.

For anyone that needs to redeem their coupon or purchase the software on Linux: user a browser and our web store instead. The only thing you need the software itself for is to check your serial and generate a discount coupon.

You’ll get your activation code sent via email. Set that aside for safe keeping, and use the “Enter Licence” button on the demo dialogue to activate. That part should work fine, so long as you have dotnet 4.6.2 installed correctly.

And yes, it works! I’m using it right now in Debian 11. :slight_smile:

1 Like

Thanks for your team’s hard work! And for confirming the procedure to get it registered.

It would be interesting to hear how it goes if someone installs IE in that wine bottle first. I presume a browser is still needed for inserting webpages into a scrivener document? Can I try installing Firefox on Wine instead?

Yep :slight_smile:

That problem is specifically with the Paddle store component, that is running through the software, rather than the software itself. They have it hard-coded to try and use ie.exe for some things, that’s actually causing problems for some Windows users as well, who no longer have it installed.

So no, installing Firefox (or even an Edge bottle) or changing your default browser won’t help.

That’s a good question, I’ve never tried it as I prefer to just archive the text I’m interested in.

Heck. Y’all beat me to it. :slight_smile:

This worked for me, too. Dotnet 4.5 is broken in WINE, but if you’re using winetricks, it should install 4.62 and above just fine, but fail installing the rest of them. It’s OK. You don’t need dotnet 4.5.

Also, in WINE 6.3 through 5.20ish, accessing the internet is hosed (see here: Scrivener 3.0, wine > 5.22, the internet, and you) This could be making the paddle license server fail.

The dialogue that popped up telling me to deactivate made me think it was another error. :smiley:

Nope, you shouldn’t need a browser. As far as I remember, Scrivener has its own little web engine it uses to render pages.

Amber, I can see the buy option but nothing about redeeming the coupon on the store page. What’s the process? I can’t use the buy option from within Scrivener because the Paddle process just keeps crashing whenever I try.

If I remember correctly you add Scriv 3 to your basket and it’ll seem like it’s about to charge you $67 for it, but before that you can enter the coupon code.

It will be there once you get into the order process. If I recall correctly the order of events is:

  1. Insert email.
  2. Region info.
  3. Then there will be a link to insert a coupon code below the payment icons.

Once you do that step, the cart should reduce to whatever your discount is for, and you can complete the order. At the conclusion, your serial number will be sent to the email address you gave in the first step.

No, I’m not seeing any place to insert the coupon code.
[attachment=0]Screenshot at 2021-03-25 08-23-46.png[/attachment]
I’ve blanked out my email address but otherwise, this is what I see. The rest of the background is empty until you get to the page footer.

Given that your image says you’re trying to purchase Scrivener for MacOS…



I hadn’t noticed that but, as I had gone through the process to purchase a Windows license I only see that as yet another Paddle issue. I’ll try again from the beginning and hope that, if I get through to the right spot, that I can remove the extraneous item from the basket.

After Mark (“xiamenese”) pointed out that the item in my basket was for MacOS, even though I went through the steps to purchase the Windows one, I tries again. I ended up with the correct item but now have another problem; When first retrying the activation from within SCrivener and it said that code had already been issued it should as much of the code as would fit in the dialogue window. The problem is that, due to my name being a little too long for it, it did not show the whole code. When I tried to use what code was shown in the purchase process it told me it was invalid.

Given that we no longer have any Windows machines in our household, what can I do to get my activation code for Scrivener3?

BTW, I now have two items in my Paddle basket with no option to delete them, What happens there?

I was given a spot underneath my total (Add Coupon) in small, red print to add the coupon code. Once I did, my total was zero, and I got my serial via email. (So put in a real email address.)

When I got my serial number (It’s twice the length of the coupon code), I was able to put it into the Scrivener activation, and it went through. Note, I have dotnet 4.62 installed via winetricks. it’ll fail installing 4.5, but that’s fine, because we only need 4.62 installed.

Here’s the place where you enter the code:


In the message you quoted a small part of, I stated the problem I have with the code. i.e. I was unable to retrieve the whole code, leaving my in a situation where I’m stuffed.