Spellchecker - making it work

There are some incredibly intricate solutions on this forum, but I found a variant of https://forum.literatureandlatte.com/t/installing-french-dictionary-on-64-bit-1-9-01-beta-linux/32417/1 did the trick:

sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/

I had previously installed libaspell-dev, libqt4-gui, and libqt4-core to no effect.

There were some .rws files in /usr/share/scrivener/bin/Aspell/dict/ already but they are shown as type “unknown”. On restart the spellchecker works, although the first time I used it it killed Scrivener. Now seems OK.

Netrunner 14.04

Following this advice I was was able to get Scrivener spelling working on my Fedora 23 desktop (after months of being too lazy to try some of the other methods). Thanks Zelator !

Before copying the dictionaries I installed:

sudo dnf install aspell-devel.i686 aspell-devel.x86_64 aspell.i686 aspell.x86_64 aspell-en.x86_64 aspell-en.i686 

On Fedora the Aspell dictionary files are stored in /usr/lib. I keep Scrivener in a bin directory for my user - this will have to be modified this to match where you keep Scrivener. So for me the command to copy the dictionary files is…

sudo cp     /usr/lib/aspell-0.60/en-*.rws     ~/bin/scrivener/bin/Aspell/dict

Thank you Zelator. Most appreciated!

This worked on Linux Mint:

sudo apt-get install libaspell-dev


sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/

You can save a little disk space by linking to the dictionary files instead of copying them:

sudo ln -s  /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/

Can someone please make this a STICKY? Amazing! Easy! and SUPER USEFUL.

Excellent! Just one extra step. I found that I also needed to install libaspell-dev. Installing only aspell was not enough; when I restarted Scrivener, I still did not see any dictionaries available in Tools -> Options -> Corrections -> Select Dictionary.

OP mentioned having installed libaspell-dev without success, so I think this may have already been present on the system and part of this solution.

sudo apt install libaspell-dev

After installing libaspell-dev and copying the dictionary files as described above, I can access the dictionaries in Scrivener. Success! Thanks so much!

I did as recommended:

sudo apt install libaspell-dev sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/

and 3 dictionary choices showed for me under Options/Corrections/Dictionary/Select!
Running Scrivener (64-bit) under Ubuntu Studio 16.10 on Asus/Centrino2/nVidia…

Thanks, all!!!

This worked on Linux Mint 18.3:

sudo apt-get install libaspell-dev


sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/


Wish granted. :slight_smile:

Wonderful! I can’t tell you how many times I tried to get this to work!!! Thanks!

By the way, I had to make a tiny modification to your instructions because I am using a different language (Spanish).

After installing the corresponding dictionary: sudo apt install aspell-es , I expected to only need to change “en” by “es” in your command. However, the file name of the Spanish dictionary doesn’t start with “es-” but with “es” (no dash).

Long story short, the command that worked for me was:

sudo cp /var/lib/aspell/es*.rws /usr/share/scrivener/bin/Aspell/dict/

Again, muchas gracias amigo!

Thank you so much for posting this! This is still working as I just applied this fix to work on Linux Mint 19.2 as just a FYI.