Surname, title not being picked up after page 1 in compiling

I wrote a short story using the default short story template and compiled it. The first page with all the front matter is fine; but the upper right-hand header of pages 2 onward lacks my surname, and the title reads ‘untitled.’ I fixed the ‘untitled’ issue but unfortunately I don’t recall what I did, and when it was working it used the entire title, not a shorter version like I know it’s supposed to. It does use the correct page number.

So, basically, instead of it looking like:

Sofranko / Goat’s Neck/ 2

It just looks like

           /untitled/ 2 (with the correct page numbers later on)

(When it was working and populated the title field it looked like

           / I wish You Stayed in Goat’s Neck/ 2.  (-the full title, not an abbreviated version)

I’m doing everything according to the template guide regarding what to do for the front matter what to select when compiling. It just doesn’t pick up my surname or the title.

I’ve looked over these forums; this has appeared before but ages ago and nothing recent, as far as I can see.

I did make sure that the My Card in Contacts was correct; I also added Author Information to Scrivener—>Settings—> General----> Author Information. I even held down the Option key when selecting the short story template and it did populate the Front Matter correctly. It was after I did all this that the thing went back to using ‘untitled’ for the header.

I cannot get it to work and my frustration level is getting high. I’ve done this before on an older Mac and didn’t have this issue. It should just grab the info right from the Front Matter, although I doin’t know how it would determine the proper short version of the title.

Hello paulcoholic. I can think of two places where the incorrect information might be coming from.

The first is the metadata tab on the File > Compile main screen. In the area on the upper-right of the main compile panel, you’ll see different tabs depending on which compile format you’re using. The metadata tab’s icon looks like a luggage tag.

I’d start by reviewing the information entered there to ensure it’s correct.

If it is, then the second item I suggest checking is your placeholders in the compile designer panel. You can double-click your compile format and then select “Duplicate & Edit.”

In this panel, you’ll go to the Page Settings area and review the placeholders being used in the “Main Body” fields on the “Header and Footer Text” tab. Scrivener’s Help menu contains a List of All Placeholders document that shows the options you can use depending on what you’d like the output file to include.

Does reviewing those settings correct this?

1 Like

Thank you, @RuthS ! The first solution took care of the problem. I never knew to go there.

One question: Where is the ‘compile designer panel?’ I don’t need to go there to solve this, but I want to look at it.

Oh excellent! I’m glad that fixed it.

If you ever want to customize your compile settings, you can access the compile designer panel a couple of ways.

One is to double-click on the compile format that you’d like to customize. For the built-in formats, Scrivener will show a message asking if you’d like to “Duplicate & Edit” the format. When you confirm that, it opens the compile designer panel.

You can also click the plus mark in the lower-left of the main compile panel and select “Duplicate & Edit” that way.

We have a 4-part video series titled “Getting Your Work Out” on the Mac tutorial videos page

Those videos demonstrate using the built-in compile formats as well as show the customization process. Seeing them might be helpful if you ever decide you’d like to experiment with your settings.

I’m a fan of using the Interactive Tutorial from Scrivener’s Help menu for testing compile settings. That way, I can be a bit more fearless in trying out the options without that gnawing anxiety that I’m “breaking” my project.