Table of Content Missing Right Tab? [Causing page number to be next to title]

V3 compiling to PDF: if Override text and notes formatting is checked for an manually created TOC page, the page numbers do not align with the right margin. The right tab seems to be missing. But it still does not work even after I add a right tab on the ruler. How can I fix this?

You shouldn’t need to override formatting for a TOC (in my experience), but if you do, then of course you need to add the tab. It’s already there in the Editor, but the layout in Compile doesn’t have a right tab.

Click in the sample text and go to the menus: Format▸Paragraph▸Tabs and Indents.

I do have right tab in the format, but still get a misaligned TOC. See attached screenshots. I could not figure out what’s going on. Please help.


Get rid of all the OTHER tab stops. The ToC has only one tab per line, and the first tab stop in your screenshot is not the right tab.

1 Like

That works. Thanks a lot!


Previously I came to ask why my table of contents wasn’t spacing right. It looks like this:


All the page numbers are wrongfully spaced and some lie (JASON19) have no space at all. I went on zoom with a fellow member here and he didn’t have any idea what was causing this because my settings were correct. He told to reinstall and doing so didn’t fix it.

Can anyone help?

Did you open a support ticket and send the project to Literature & Latte? It looked like a straight-up glitch to me. Possibly a corrupted format or project. I once had to rebuild a compile format from scratch, exactly as it was before, and the problem went away. Mysterious but solved.

Literature & Latte Support

In the Section Layout pane, chose the section for your TOC, place the cursor in the body text, remove all the left tabs and leave only one right tab at 6". This works for me.

It didn’t work at @Dinok0618 ‘s machine. It should, but it didn’t.

Hi @Dinok0618, what may seem an idiot question: before you re-installed, did you clear your browser’s cache and re-download from Literature and Latte?

If the installer you downloaded before was slightly corrupted and you re-installed using it, then doing so wouldn’t solve the problem. And by clearing the browser cache, you ensure that it is a completely fresh download that you’re using.



1 Like

It’s worth noting that a number of our built-in compile formats have a dedicated “Table of Contents” section layout that is set up to provide the best result with the least amount of effort. Just create a Section Type for your ToC entry, and then assign it to the correct Layout in the Assign Section Layouts area of compile overview.

The most common cause for layout damage during compile has to do with tab stops being misaligned though. Maybe you pasted the ToC before setting things up, and it created a tab stop suitable for A4, then you selected Paperback as your compile format. The smaller paper size will make the page number tab stop invalid and cause layout problems.

The next most common flaw is assigning your ToC to a Section Layout that completely overwrites tab stops in a way that works better for body text—that was the problem noted at the top of this thread. That’s what this looks more like to me, but it’s hard to tell with the forum’s formatting, since it doesn’t have tab stops.

It was properly formatted in the Editor and we tried both checking and unchecking “override text and notes formatting” in the layout. I double-checked everything I could think of, and I saw no reason for it. The layout had lots of tabs, none of them right, but unchecking the box didn’t solve it. The output was centered either way, which it shouldn’t have been with as-is compile.

Here is the ToC, rarin’ to go pre-Compile.

Look at those beautiful dot leaders, racing across the page. But alas, after compile, this is the result: weak or no dot leaders! How can I fix this?

Where are these hidden? I can’t find them.

None of the Layouts are ever hidden in this view, but if you are in fact using the “Default” Format to compile, as it looks like from the screenshot, then I don’t know how your font family is changing so dramatically, nor the tab stops that would have normally come through from the original, since as you can see, “Main text formatting will be based on how text appears in the editor”.

But otherwise the answer is one that can be discovered through exploration: if you select a Format in the sidebar, like “Manuscript (Times)” and view its Section Layouts as you have here, you will find a layout for the ToC. Others might not have one, like “Enumerated Outline” where it wouldn’t make sense to have one since the output basically is a list of contents itself. “Default” has nothing special like this, because it is purposefully generic.

Still can’t find them:

Anyone? Bueller?


Did you select Section?

If I click on “duplicate and edit format” I get a different screen but I can’t find the built-in ToC formats.

Compile Formats can be found in the left column of the Compile Overview window.

The “Assign”-button will connect a Section Type to a Section Layout.

Section Types are created in Project Settings and usually applied throug a document’s context menu.