TOC compiling problem

Hi guys,
When I compile a Table Of Contents for PDF, after following the advice online (special characters for page numbers, copy special, copy documents as TOC etc), the output’s format is changed. It does not have the line of dots leading to page numbers, instead it puts question marks on the line underneath.
If I compile and export to Word, the line of dots leading to the numbers is maintained, though still with the question marks.
Has anyone seen this before?
Mac user

Hi guys,
I’m still scratching my head over this one. Since I’ve had no replies, I figured I’d give some more info.
I have had an issue with compiling with TOC in Scrivener 2. I have updated to Scrivener 3 with the same issue.
I highlight the document that I want to include in the TOC, then go to Edit, Copy Special, Copy documents as TOC. I then create a new document. Paste into that document. In the new document I see the TOC complete with Chapter Name, the dot leaders that lead across the page to <$P>, so all looks fine. It looks like this:
Arrival _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ <$p>
Departure_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ <$p>
Return_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ <$p>

When I compile to PDF or Print, the output is different. It is Chapter Name, no dots across the screen, then the page number on a new line. It looks like this:

Chapter One Arrival
Chapter Two Departure
Chapter Three Return

I want to know what I’m doing wrong. Why are there no dot leaders, and why is the page number on a new line?
Is it a software fault? Is it a formatting thing? Is it indents or page margins?
Please help me. I’ve never before researched for so long without finding a solution to something. Writing a full manuscript has been easier than finding a solution to this.

First, it helps me to turn on invisibles so I can see what’s happening with page formatting (View > Text Editing > Show Invisibles.) It also helps turn on the page ruler ( View > Text Editing > Show Ruler)
Screenshot 2017-12-05 14.47.47.png
As you can see, it’s an ordinary tabbed list, with specially underlined tabs. From what you’re showing, I’ll bet your right tab stop is set too far right, past the margin of your PDF page, (or maybe not even set). Try adjusting the tab stops in your document. If that doesn’t work, try adjusting them in your compile section layout.

Thanks for the response Silverdragon,
Those adjustments were just what I needed. I played around with the Tab Stops until the right formatting was found.
Thank you so much for getting in touch.

You’re welcome!

Silverdragon, maybe you can help me out here: why can’t I compile with a table of content that shows the correct page numbers? Now it’s either showing question marks, or telling me everything is on page 2 (which is the page number of the ToC itself)

Kind regards

Did you create the ToC as described in the manual? Copy… as ToC?

Yes, I did. I’ve tried various output formats and various export conversions for those formats. Still only page 2’s or question marks .
Well, there was one rtf-file that showed page marks, but they were wrong.

It sounds as if you manually inserted the page references.
Did you really do it as described in the manual, after your Binder structure was complete? If you change the binder after making the ToC it also breaks.

Of course I didn’t change the page numbers manually. That’s what I’m trying to avoid.
I’ll try deleting and recreating the ToC though.

I srote references, the code, not the numbers.

I’ve read the manual again. In the “Things To Watch Out For”-section it says:
“When first opening the compiled document in Microsoft Word, you will need to
generate the ToC numbers by running a test print preview once; they will appear
as question marks until you have done so.”

That I did, and behold the question marks changed … into number 2’s. In other words, the ToC references to itself. I’ve read this on various websites.

So, how to fix this?

The OP asked about compiling to pdf, not to Word. And now you tell us you compile to Word??

I have never bothered creating a ToC for Word because it can easily be done in Word. So my replies concern compiling to pdf.

I didn’t do that either. That’s also something I’m trying to avoid.
I did it all over once more:
-I selected the chapters and subchapters in the binder
-Under Copy Special I selected Copy as ToC
-I added a blank file as a first page
-I pasted the ToC on that first page
-I compiled as a DOC-file
-I opened the DOC-file with Word 2013. The page numbers were all question marks.
-I went to Print, so the program generates a preview
-I saw the question marks change to 2’s (that’s the page the ToC is on)

Do you see any possible errors, or better yet, any possible solutions? It’s not like I’m the only one who experiences this problem.

Well, it didn’t work with PDF either. Still shows only page 2’s. So it must be something else.
Actually, I didn’t think it would matter to what output format I would compile for the ToC to succeed.

Yes, I want to compile to Word, to a format that can be changed. The tutorial has made it abundantly clear that Scrivener is not a word processor, that other programs such as Word can do that afterwards. So, yes, doc or rtf or docx would fit.

Any other ideas?

It works with pdf. I have done it numerous times.

Your profile says you use the iOS version…?

It finally worked when I exported as an RTF, then went to print preview back and forth a couple of times. Suddenly the correct page numbers were there.

I still find it strange that this doesn’t work in doc, docx or pdf. If anyone has an idea about that, please let me know. For now, I can move on.

It works for pdf:s

Good to know that it works. But I’ve tried all the steps and in my case only number 2’s are generated. If you can identify what I’m doing wrong, I would surely appreciate that, Lunk.