Trouble with Scrivener on iPhone

I have scrivener on my Mac, iPad and iPhone. It works fine on both my iPad and Mac, and syncs between all three, but since updating my phone it won’t open the projects. I don’t get any messages or errors, it simply doesn’t do anything when I click on a project…

Any ideas what can be wrong?

I reinstalled the app and that made it work for five minutes before it went back to not working…

I’m having the exact same issue since 13.1.2 installed itself last night. It couldn’t have happened at a worse time either, I do 99% of my writing on my phone when I am away and I leave this Saturday for a week!

Exactly! The timing was really bad…

Hi having exactly the same - just doesn’t open any projects

I’m having the exact same issue. I was using Scrivener without issue at 6:30am Eastern and when I went to write more around 10am Eastern the display/format of my App had changed (even though I hadn’t updated the app) and wouldn’t allow me to select or open my project. I unsuccessfully tried to send my book to Dropbox but that didn’t work. I’ve sent an email to Scrivener support and am now waiting on a response. Hopefully it’ll be fixed quickly if all IOS users are experiencing the same thing.

I’m having the same problem. Everything appears to be correctly synced via Dropbox but touching a project does nothing at all.

I’m on iOS 13.1.2.

I also cannot open a project that I just created on my phone (selecting the option not to sync it to Dropbox.)

Hello, as I’ve seen other people complain about, the Scrivener app since updating to iOS 13 will fail to recognize the Scrivener files of projects I made prior to iOS 13, which are in my usual designated Dropbox folder. Any new ideas as to how to fix the problem or must an update be awaited for?

I managed to get it working if I set my iPhone to Dark Mode. Then it reverts to the previous layout for opening projects. Yet if I go back to Light Mode it no longer works.

Tried that for me. Didn’t work.

Didn’t work for me either…

The first inquiry about this issue seems to be September 26th, so we’re entering the third week of non-functionality. I’ ve jumped through every suggested hoop/hack trying to bypass the problem, and no go. It appears as serious as the MacOS Catalina issue, but the official response is frustrating.

IPhone 11 Pro
iOS 13.1.2

I realise this is frustrating in the extreme, however issues such as this that impact a (statistically) small number of users can be damned difficult to track down and then fix.

Even Apple who own the hardware and OS can take several months to resolve bugs of this nature. Irate customers and Apple going back saying they are still trying to recreate and understand the issue. Once understood, a fix has to be developed then thoroughly tested to ensure it has no other unintended consequences.

As Scrivener was working fine before the latest iOS updates I’m guessing Keith is scrutinising code to see if the issue is Apple’s (and providing them feedback) or from the changes to make Scrivener compatible with the latest update.

Switching to dark mode worked for me. It reverted to the old project UI where everything seems to work correctly.

I got it to work by switching to dark mode too now; had to restart my phone twice after switching to dark mode then it reverted back to the old Scrivener.

Switched to dark mode, restarted the app, and it reverted to the old interface and worked fine.

When in light mode the interface is icon-based, like boxes for each project, and unresponsive other than the ability to create new (unresponsive) projects, rename projects, and sync everything with Dropbox.

Now I understand why was working last night but not this morning!

Why not set the interface so that it’s the same for dark and light mode until the light mode version can be fixed?

Dark Mode workaround: tried and failed.
Switched to Dark Mode, restarted twice, deleted and re-installed program.
Hit the Sync button and the program dumps to the Home screen, though the program still comes up as active in the background.

IPhone 11 Pro
iOS 13.1.2

I am also having this problem.
I turned on Dark Mode on the phone as soon as it updated and I was already using dark mode within the Scrivener app,

I tried creating a new folder in Dropbox, created a new project on the phone in the new folder, synced no problem.

Then I tried adding my scrivener files from the original folder to the new folder and it went back to closing Scrivener after about 30 seconds of attempting to sync.

Very eager for a solution to this problem.

I had the same problem on my iPhone 7+ after upgrading to 13.1.2. I got it working by going from Dark mode to Light and restarting Scrivener on the iPhone. Then the non-responsive project icons returned to the list option and I’m able to access the projects.

Some additional poking around with the settings gives these results:

Iphone = Dark Mode, Scrivener = Dark Mode - Scrivener works as expected for both local and synced projects
iphone = Dark Mode, Scrivener = Light Mode - Non-responsive project icons
iphone = Light Mode, Scrivener = Dark Mode - Non-responsive project icons
iphone = Light Mode, Scrivener = Light Mode - Scrivener works as expected for both local and synced projects

Hope that helps

Mac, Windows and iOS

Alright, tried the light/dark mode switcheroo::

Iphone = Dark Mode, Scrivener = Dark Mode - Start sync, program window drops out (as before) to home screen - but program is still live

iphone = Light Mode, Scrivener = Light Mode – Start sync, program window drops out (as before) to home screen - but program is still live

IPhone 11 Pro
iOS 13.1.2