Untitled files no longer show synopsis

Hi, I dont know how to look this up so if there’s already a way to fix it please direct me to it. Its been a couple of days since opening scrivener and it showing me an error. Something about a table error, missing or not working and since then, all of the files no longer show a synopsis. Id love to cite the error but I closed it very quickly by mistake so I could only catch a glimpse of it. Before that the file or folder would show a synopsis if it had no title. Also, when in outliner mode, if it has a synopsis and a title it only shows the title unless I scroll manually to each and every one and re open the outliner to know what Im working with. Its very annoying and I’d like to know if there’s any way to fix this.scrivener issue

For the second one: Do you have “and Synopsis” marked in this menu?
Might help with the outliner part.

To the table error - probably the devs or whoever is technical on the forum would benefit from actually seeing the error.

Thanks for the suggestion. As far as the option for the outliner, it was already marked, as a couple of synopsis can be seen in my picture but the rest dont appear, even though they have them.
I dont know how to look for the error that Scrivener mentioned, as it only appeared once and I closed it almost immediately by mistake.
scrivener issue

Unless a dev/support answers, you can try:
Making a backup of this one
Creating a new project
Moving the entire documents to the new project
And then check what happens to that display.
I’m guessing some file in the project got corrupted.

An “empty looking” project can sometimes be a side-effect of an overzealous security program restricting Scrivener from opening its own files. Basically the binder file will open, which shows you the list of things in the sidebar, but the content, synopsis, notes and likely other support files will be inaccessible. Here is a thread with some tips on that.

I would suggest also uninstalling, downloading a fresh copy from the website, and installing again as well, just in case it’s a simple matter of the software itself being damaged.

Tried reinstalling and that did not work.

What fixed it was editing each and every file one by one. This works both with the editor and with the synopsis. Ive attached a picture with example. The one that says “Test to see if binder and outliner synopsis stay after updating” is just editor text. The rest of the synopsis that appear were edited by adding a space at the end and saving. This has survived both closing scrivener and a full pc restart, so I believe it will stick. Thanks for the suggestions!

scrivener issue

1 Like

Very strange! I wonder if it might have also worked to use the File ▸ Save and Rebuild Search Index menu command. That would force the program to go through and read all of the .txt and .rtf files again, which is a slower process than just reading the index file as it does on load. If the index file was damaged, it could explain why everything came up empty looking.

It might not be a bad idea to run that command no matter, just to be on the safe side.

Testing the hypotesis of using File ▸ Save and Rebuild Search Index
This is a backup of the corrupted index file.
scrivener issue
This is after running File ▸ Save and Rebuild Search Index
scrivener issue 2
It seems like it does not work, however, after closing and reopening the project, all the synopsis have been updated both in binder and outliner

File ▸ Save and Rebuild Search Index seems to fix the issue right up. Thanks again for the suggestion. Just replying for archive purposes in case someone bumps into a similar bug in the future.

1 Like