Unwanted empty space at bottom of pages

Hi. When I try to print or compile, I get a large amount of white space at the bottom of each page. I have looked at the comps and scrivener/print settings, and I have looked at the invisibles, but I don’t see why it’s doing this. Any ideas? Thanks

It looks to me like what you’d get if your setting for a page was smaller in Scrivener than the page size your printer uses (a standard 8x11).

Check the page setup of your project. Set it to “letter” if not already.

File / Page Setup (under windows).

How did you get to this point (the print preview) ? Compile ? Straight to print ?

Under printer is’s : US Letter 81/2x11; Portrait, Scaling 100 (under ScrivernerPrint: margins all 1"; texxt and page number selected; Other: print actual size.

I have tried it under compile and under regular print

Windows screenshots :



Mine looks like this:

Stupid question (most likely), but those texts are longer than a printed page? As opposed to short scenes.

1 Like

Yes. Wouldn’t’ve thought of that, though.

Alright. There’s still a small chance that page breaks somehow made it into the document (e.g. via copy & paste from Word), I think. :thinking: Or is this something you can rule out?

It’s at the bottom of every printed out page (printed out on a real printer and in previews and compiles.

Also I looked here:

I can rule that out.

What happens when you print to PDF? (via the print dialog)

Or compile to PDF… ?

Still there…

Weird. Are you on Scrivener 3.3.6 ? I recall a recent problem (that got fixed) with cut off lines. Not to this extent, though.

ADD: Just to make sure. If you select a text (in Scrivener) where that problem happens, that’s what an artificial page break would look like:

I don’t see any of those.

I did try something that worked, but I’m not sure what worked exactly. I 1) I did a Cntl-A and selected all the text (with and without footnotes) and 2) placed it in TextEdit (which I think strips all the excess coding off of it, so it’s just plain words, or something 3) copied that text and put it inside Scrivener. What would this tell you I’m doing wrong on the front end?

Screenshot 2023-10-27 at 2.44.02 PM
and it looks like this:

That’s a hint. Try selecting your text in Scrivener, and then Edit → Text Tidying → Zap Gremlins. (If that doesn’t help I start to suspect the footnotes.)

:slight_smile: tried that item and the other ones in there, too. Didn’t work.

What would you suggest with footnotes?

Bottomline I can always strip the text in TextEdit and put it back, but it would be a pain…:slight_smile:

Wouldn’t that also destroy the footnotes? :thinking: This can’t be the solution…

Reminds me of this. It’s possible that you’re the lucky one to discover a related bug. Not sure at this point.

But what you could test in the meanwhile: A full page (lorem ipsum or whatever) without any footnotes. Does this print as expected without workarounds?

View → Text Editing → Show Invisibles can help identify “invisible” formatting issues like this.

Was this text originally created in Scrivener, or elsewhere?

Originally created in Scrivener.