Unwanted Gap Before Each Scene In Compile

There is a gap, a line break or something, before each scene in my compiles, so that each scene starts a line down the page rather than the first available line (as other text appears on the following page, for example).

I have tried all sorts of combinations in the compile settings, but I cannot get rid of this.

Can anyone help?

Hi.
In your compile format (accessed by double-clicking it, left side of the compile panel),
I see you have your separator set to “custom”.
That is most likely what is inserting the undesired empty line.

Set your separator to “page break” :
Or to “single return” if you don’t want a page break between scenes.

Do it for “Folders” and/or for “Files”, as needed, depending on your draft’s structure.

Or simply in your section layout(s) (just below) if unchecking “use default separators”.

Inked2022-03-27 14_05_38-Window_LI

Inked2022-03-27 14_32_36-Window_LI

Unfortunately though, that will not prevent paragraphs from being split across pages.
That feature is not yet available under the Windows version…


Another possibility is that perhaps you have an unwanted carriage return in your title options
image

Or in the “prefix” tab
2022-03-27 14_38_06-Window

1 Like

Hi,

Thanks for the reply and ideas.

Tried all of those, but none are making any difference I’m afraid.

I only changed the seperator settings in the 1st place to try to fix this. But changing doesn’t do anything for me.

Any other ideas?

Has anyone else had this happen? Seems like a bug to me.

By “in the first place”, do you mean you only changed it for the default “Folders” ?
If your documents are of the “Text files” type, that would indeed change nothing.
Plus, some of your section layouts (just below) might not even be using the defaults…

I also see that you don’t tick “title” in your section layouts. If you are inserting your titles manually in the editor, make sure the style you use doesn’t have a space before that might be the cause of your issue.
. . . . . .

Also verify this (for each of your layouts) :
Inked2022-03-29 15_52_23-Window_LI
(Sorry I didn’t think of this last one earlier…)

1 Like

These settings we’re describing do work, but finding out what you’re doing (or not doing) in sufficient detail in text messages may wear you out before you get there.

try a Zoom session instead

Yes, I’m not saying these functions don’t work at all, sorry if that’s what came across. Just that they are not solving the issue I’m currently wrangling with.

The gap before scene headings was in my first compile using out the box, untouched settings. I then tried to fix by changing ‘Folders’ and ‘Text Files’ settings in Separators sections in compile. Nothing has changed (with regards the present gap before scene heading). It has not changed after changing these sections from custom, to return to page break. So I think the issue is being generated somehwere else.

Not sure if has anything to do with my script numbering code in the header?

Again, “title” unchecked in all of your layouts…
Where are your titles coming from ?

From the editor itself ? [Edit] just saw your last screenshot. You have your title in the editor.
Check your style/paragraph “space before”.
→ You want it set to 0.

And also in the “styles” panel of the compile format.
You might have an override of your header style there.

Don’t worry about your <$n>

1 Like

If you mean the scene heading, then yeah it’s just written manually into each text file, like you say in the editor.

Not sure where you mean to check the style/paragraph…?

You mean here?

There there there !!!
It’s at 24.00pt
Make that 0.00pt

Assuming you’ll use a page break between scenes ?
Was that your plan?
Or do you only have an issue with your very first scene ?

1 Like

Awww. THought we had it then. But alas, no. Problem still there.

All scenes.

I want a page break, yeah. That is working. But the problem is that each new scene, and it’s scene header, annoyingly starts 1 line down from all other text, as you can see when compared to text on opposite page.

After you had set the “space before” from 24pt to 0pt, did Scrivener ask you about converting your script documents ?
What did you do ? You clicked OK ? Twice ?

1 Like

I just did as I told you to do, and all is fine here compiling using the “script or screenplay” compile format.

Make that nasty useless 18 disappear :
image

image

Set that to 0pt too. → 1.5x 0.0/0.0

→ P.S. If you don’t have the habit of making backups, now would be a very good time.
If you need to, hit cancel, do a backup and start over.

Otherwise, make sure the space before is still set to 0.00pt, then hit OK all three times.

1 Like

Hit Ok to next pop up window too, which asks about altering template or something.

But still no dice…

Only twice though. Initial ok, then a pop-up, hit ok. THat’s all.