Zap Resistant Evil Gremlin

This showed up in my Scrivener project. Was probably copied over from another document.
I can’t delete it.
No matter what I do.
Tried Zap Gremlins.
This is Zap resistant.
Work around is copy everything to a text editor, delete the file, then copy it all back.

This gremlin also affects the following font size. It defies editor and Compile font settings.

Do you know what the character is? If you use VSCode there is an extension to give you a unicode codepoint for any character: Name: Unicode Code Point - Visual Studio Marketplace

I have no idea. The idea of dumping a Scrivener file into a hex editor is daunting. I know it’s not this one: • because that can be easily erased.

Dumping an RTF file into a hex editor is indeed far from ideal. My recommendation was to use VS Code with a simple copy-n-paste. I assume other editors like BBEdit can do this too, but VS Code has replaced all editors for me… Can’t you copy and paste it here and we can try to work out what it is?

I’ll try. Copying from Scrivener:

Nothing appeared.

I tried copying into a hex editor (Hex Fiend) but Ctrl+v yielded: nothing.
I tried copying from before and after which yielded this (attached).

This forum won’t let me upload a hex file.

I have two suggestions:

  1. Wait until Halloween is over.
  2. Could you move the document with the multiresistant gremlin into a new project and upload it?

Can you upload Scrivener or zip files? I’ll try.

I opened a new project, copied the gremlin and its neighbors, pasted into the new project but the gremlin was gone. Tried copying as html and got this:

(which doesn’t display in the forum)

Perhaps the “Apple-converted-space” is the gremlin?

The other option, which will take more time, is to duplicate the project, delete everything except the gremlin and then upload the duplicated project. This will take a little time but I’ll try.

Split doc a bit before gremlin line, split doc a bit after gremlin line. Toss resulting tweener gremlin doc. Merge the two remaining docs. Gremlin gone.

Recommit to always using Paste and Match Style.

Interesting deletion method. Never thought of that.

Where in the text is the character in question? Going by the text from your HTML (“What follows in this chapter…”) I don’t see any odd characters there (the space character you mention isn’t anything odd), but I’m wondering: Are you viewing the text in Scrivenings mode using the “Bookish” separator? That places a • character between sections displayed in the editor which wouldn’t be deletable.

You can change to a different separator in the Appearance tab of Scrivener’s settings under Scrivenings: Options.

If you look at the graphic in my first posting, you will see the nasty critter.
If you look at the .scriv project file I uploaded ( you will find him hiding there in the project’s sole document.
I tried to copy the demon to the forum, but that was not possible.
It’s definitely not the • character; that I can • add or • delete all day. •••••
And it’s not a Scrivenings addition either.

I also learned that ctrl-x doesn’t work in a Scrivener document.

I was looking in the project you uploaded, but that project contains four lengthy text documents within a folder with text of its own. What is the text just preceding and following the character? That would help locate it in the project.

It’s definitely not the • character; that I can • add or • delete all day. •••••

Sorry I was unclear. The point was that in Scrivenings mode, one of the separator types that will be added by Scrivener in that display mode appears as a dot character of that nature, but within Scrivener it would not be deletable or copyable since it is not actually part of the document text.

I didn’t see any • but as @MimeticMouton mentioned that could be some Scrivenings thing. You have 4 formfeeds (U+000C, ascii 12) in those files. VS Code immediately highlighted them and specified the exact unicode codepoint:

It is here > <

You can search for \u000C or \f using Scrivener with regex enabled to find each of those and then know where they are to remove them. If you look closely Scrivener does visualise them at least in my editor:

Perhaps it depends on the system and font and Scriveneings may trigger with a formfeed, for what exactly gets shown. Does removing them make any difference?

Sorry, I forgot that the specific chapter had several subdocuments, which meant finding the ornery critter could be a challenge.
This version has but one document, and the gremlin is centered after the first sentence of the document, it looks like “•” but is not “•”. (83.3 KB)

Thanks for explaining how to find form feeds. Indeed, they cause problems but fortunately, they do not resist deletion. There’s no way to delete the evil gremlin besides @gr’s idea of splitting the document before and after the critter, and then deleting the new document populated just by the gremlin.

Form feeds, on the other hand, can be deleted in the normal fashion. Finding them, as you point out, is trivial with regex if that is enabled and if you know the code and if they are there.

There is no there there. Opening the RTF files directly in either VS Code or Hex Fiend and there is no rogue characters in the documents:

I do not see any • in your documents because my settings for Scrivenings are different. this is an editor Setting not anything in your documents; I use Divider normally and you are using Bookish, if I switch to that setting then i see the •

I don’t use Scrivenings. It may not be there, but you can see it, at least in the editor. I remember when I compiled the text thereafter was…weird. Then again, there were several instances, for example, where Compile at random sprinkled the bold command, uncommanded in single paragraph. Also, to get an rtf file, didn’t you have to compile? Maybe the compile process killed the evil gremlin.

In any event, it can’t be a program feature to display a symbol that looks like a bullet–but isn’t–in the editor which cannot be deleted.