Footnotes and Chinese

Over the Christmas period, an issue arose in the Mac forum

about using the footnote marker in Chinese text. The issue arises because Chinese doesn’t use spaces between ‘words’; no matter how long a Chinese sentence is, it is an unbroken string of characters/glyphs. Chinese punctuation marks are also technically characters, occupying the same space as the others … think of it as if you removed all the spaces from this paragraph.

While doing some testing today, I thought it might be useful to test what happens with the Windows 3 beta. I opened the project which I had been using to test Mac-Scriv 3, which already had footnotes with footnote markers. Here’s what I found.

Although, under Project > Project Settings > Formatting I ticked “Use footnote marker” and clicked “Make Default”, when I entered a footnote, Scrivener didn’t use the marker, but still used the highlight. However, since Chinese doesn’t use spaces in the text, the stretch highlighted runs all the way from the cursor to the preceding non-Chinese character. This includes % signs and the footnote markers inserted by Mac-Scriv, but not standard Chinese punctuation, equivalents of full-stop/period, comma, etc.

This has two results: (1) clearly, you can’t go back and enter a new footnote anywhere in that stretch—assuming you’re like me and often need to do that as working further down the text brings new issues to light in previously worked text—as it is already marked as having a footnote; (2) and more importantly, you cannot edit that text without removing the footnote first … clicking anywhere within the text apparently takes the cursor to the end of the marked stretch, and if you start typing, the whole stretch is deleted and replaced with your current input.

Oh, and I also found that in Scrivenings mode, it is impossible to enter footnotes; the menu is greyed out and Shift-F5 has no effect. It works as above in single document mode.

That is using Win-Scriv 2.902 under CrossOver. It would interesting to see if there is any Chinese speaker using it under Windows and whether their experience is the same.

I hope this is useful for the devs.



Apologies to the moderators and devs. On further testing, it seems that, although the UI for using a footnote marker such as * rather than highlighting is there, the code for doing so has not been implemented yet. Also, on further reading, known issues include not yet being able to edit across Scrivenings borders, so presumably the greying-out of inserting footnotes when in Scrivenings mode is related to that.

The issue which turned up in Scrivener 3 for Mac using footnote markers in Chinese, is one I will look out for as the Windows version progresses, and will post back on any concerns I find.



Thanks, Mark! We’re still fixing up the project-specific formatting, as you note, but once we have the footnote marker implemented, it’d be great if you could give this another test with the Chinese text.

Text isn’t editable at all in Scrivenings mode at the moment, but of course it should work the same there as well.

Thanks Jennifer. Having realised all of that, I will continue to check as each new beta comes out. I’m not doing any other beta testing as I don’t need it myself, and you’ll get better feedback from Windows users and those using it on Linux under WINE like @garpu and @StaceyUK.

But I’ll keep an eye on the Chinese side of things for you all.



Would like to jump in and say, even though I haven’t used Chinese text in Scrivener in quite a while (and never with footnotes as described here) I am a Windows Beta user and would be happy to test this going forward as the beta versions with the footnote marker come out.

Thanks, FadedStardust! We’d definitely appreciate it.

Version under CrossOver 17.

On first installing the 64-bit version, it crashed immediately after opening. I posted in the WINE thread in the Linux area including the backtrace, and also sent the data to CodeWeavers. They suggested trying the 32-bit version, which had already occurred to me. So I installed that today. Outcome? The 32-bit installed and ran OK, so I tried the 64-bit and it too ran OK! Go figure.

However …

In both versions for me, the Inspector Footnotes don’t display. If I hover over a marker for an existing footnote, the text is shown in a tooltip, but doesn’t appear in the inspector. If I try to create a new footnote, a tooltip appears saying "Footnote: " and again the inspector merely says “No text loaded”.

I don’t imagine that it matters that the text is in Chinese.


Mark … 57&t=50675 Is this the same issue?

It might be. That thread didn’t exist when I posted on this one. I’ll have to try with another project with more documents, or perhaps I’ll split the text in order to check.


Hi Mark. If it is the same bug, then the comments and footnotes should reappear after you select a different document in the project and then return to the document they were missing from. Does selecting a new document fix the issue for you as well?

Thanks Bryan.

I wanted to try that, but my test file only had one document. So I thought I would split it up, only to find that split, neither “Split” nor “Split … Title”, work for me, whether from the menu or using the keystroke. I was going to post separately about that today.

So I then thought I’d use the Mac version to do the splitting, only to find a real puzzler, but which I’m sure is something to do with two projects with the same name, but one visible to CrossOver, the other visible to MacOS . So I’m in the process of creating a totally new test project to try it.

I’ll post again when I’ve checked.


Hi Mark - Just switching to the Research folder and back to the original document ought to do it–it’s just a matter of needing to reload the document in the editor/inspector.