Help with setting paragraph default settings

I know I am being dim, but I am so frustrated. I want the default settings for my work to be the first line of a new scene (text file) and the the following lines in that paragraph NOT to have an indent with the paragraphs after that to start with an indent. I think that is called the tab? I just want that to happen automatically and I think I can see that’s what it looks like in compile, but I need these settings to apply as I am writing. I have watched so many videos and read advice and changed so many settings that I am now utterly confused and anxious. Before, while not having no indent on the first line I did at least have indents for new paragraphs and now I don’t even have them. I am not techy and the videos etc just move too quickly for me. Would someone be kind enough to give me an idiot’s easy way to set this so I can just get on with my book? I would be very grateful as I have spent this morning’s precious writing time going round in circles. Thanks in advance for any advice.

Set your default formatting to no indent, create a style FirstParagraph with 0.25" first line indent. Set No Style as next style.

Type away.

Sounds like the opposite of what she wants :thinking: but the general direction makes sense. How would the “First paragraph” style apply automatically without a document template?

Good idea! Create a document with a empty paragraph with a FirstParagraph style and drag it in the Templates folder.

There are way more paragraphs needing an indent, so it’s smarter to use that as the default formatting. Only after Chapter openings and Scene changes you’d need the FirstParagraph style.

Which reminds me: if you use header or subheader styles, set the No Style as next style in those styles as well. And you might include them in your template…

In case the first and second paragraph swap places later, the “First”-style has to be (de-)applied manually again. Might as well just use the keyboard shortcut (Control-Option-Command-Left Arrow) to remove the unwanted First Line Indent and call it day. There’s no real perfect solution for it, other than stop obsessing about it and moving on. Been there, done that (evidence).

That happened once in my last book. I’d love to have the Styles Panel as a permanent tab in the Inspector, now I have to press Win+Alt+S, select the paragraphs and click the correct Styles.

I may be being dumb, but believe you can set that when you compile, that the first paragraph is not indented.
If so who cares whether indented in a scrivener project as the vast majority of the time to share and certainily to publish will use the compile function.

1 Like

How would that be different from the status quo? (Unless the proposed “styles tab” is the active one all the time.)

Well, the OP does. :smile_cat: (“I can see that’s what it looks like in compile, but I need these settings to apply as I am writing.”)

1 Like

Well, I would have the Styles tab in the Inspector open as I was writing of course. It would be more permanent than the current Floating Panel. Probably because I’m restarting Scrivener all the time. :grin:

Because all tabs in the Inspector are Binder Item related, and Styles are not, it probably won’t happen. In the mean time, I just position the panel exactly over the very empty Comments and Footnotes tab pane, until the next restart.

1 Like

I’m not against a more flexible Inspector.

The fundamental issue here is that the first paragraph of a document in the Binder is not necessarily the first paragraph of a Chapter (or other section) in your output document.

So while it’s possible to use Styles to force indents to work this way, doing so would limit your flexibility to use the Binder and Editor as designed. Every change in document boundaries – splitting/merging two scenes/chapters, moving the closing paragraph of one document to the opening of another, swapping the opening paragraphs around – would have formatting implications, which is exactly the opposite of Scrivener’s intended approach.


So, what is the best practice for setting no indents on first paragraphs an indents on all other paragraphs in the Main Editor, if not using Editor Styles?

I followed Keith’s advice (when I still cared about it in the editor). It’s best of both worlds, not using a style and getting it the way you want, with the same amount of work(around).

Best practice is to let the Compile command do it.

Second best is to increase/decrease indents on a per-paragraph basis.

Thanks for your suggestion.

Thanks for your help.

Yes, I had spotted that, but I’m an editor by profession and just don’t like writing text that has to be corrected later. Thanks for your reply.

I appreciate your support - thanks. I am still frustrated as the text isn’t responding to any of the suggestions in the forum. I think I am going to have to write in Word and then copy and paste it into a text doc in Scrivener at the end of the day. So annoying as the main reason I paid Scrivener was for the other functions as I go along rather than just the compile function. I’m sure I will crack this issue eventually (very new to Scrivener) and will report back. Thanks again.

Sounds like, by de-emphasizeing attention away from Scrivener’s compile function, you are expecting the Scrivener to be like Microsoft Word and do formatting in the Scrivener editor? I suspect that’s not going to work out for you, and maybe Microsoft Word is the right tool for you? :wink:

1 Like