Installing Scrivener 3.1.1 on Linux (Wine 7.0) without problems

I have just managed to install 64 bit Scrivener 3.1.1 on Ubuntu 20.4 using Wine 7.0. It needed not fixes or adjustments and appears to run without problems. I am sharing this for two reasons:

  1. I hope this experience could be useful to others wishing to run the latest version of Scrivener on a linux installation. Below are the steps that I followed for the installation.
  2. I would appreciate feedback on any potential problems. I should mention that I have no experience of Wine. I did my first installation yesterday following various blogs and using my judgement. I am in the process of learning Scrivener (I use it on a Mac). I have not experienced any of the problems that people have mentioned in the forum, but it might be that I have not worked enough with Scrivener. So far I have been able to open, close, edit and compile documents and I also have no problems with accents (dead keys).

Installation steps (for Wine and then Scrivener)

Following the steps on the Ubuntu - WineHQ Wiki page in a terminal window using Ubuntu 20.04

  1. Enable 32 bit architecture (I don’t know if this is necessary but I did it anyway):

    sudo dpkg --add-architecture i386

  2. Download and add the repository key

    wget -nc
    sudo apt-key add winehq.key
  3. Add the repository and update: Install Wine

    sudo add-apt-repository 'deb focal main'
    sudo apt update

  4. Install Wine 7.0 with:

    sudo apt install --install-recommends winehq-stable
  5. Intall Winetricks

    sudo apt-get install winetricks

    The version that I installed was 20200412

  6. Install dotnet462 (from a suggestion in a post by AmberV)

    winetricks dotnet462

    This gives the following message:

    This package (dotnet462) may not fully work on a 64-bit installation. 32-bit prefixes may work better.

    (As far as I can see there were no problems despite the lack of a 32-bit prefix)

  7. Configure Wine


  8. Choose Windows 10 from the menu as the default Windows version. I have not used Windows for a couple of years, but thought it best to use the latest version

  9. Downloaded Scrivener for Windows (64 bit) from L&L website to the Downloads folder

  10. Created a Scrivener directory in ~/.wine/drive_c/Program Files (which was created by the wincfg in Step 7 above)

  11. Copied the Scrivener-installer.exe file to the directory: ~/.wine/drive_c/Program Files/Scrivener

  12. cd to ~/.wine/drive_c/Program Files/Scrivener and then run:

  13. wine Scrivener-installer.exe

  14. Scrivener installs itself and creates a shortcut on the Ubuntu desktop

  15. Right click on the shortcut to allow launching and then double click to run Scrivener 3.1.1

    I hope this will be useful to others. Those who have more experience with Wine and Scrivener may be able to suggest modifications, but as I said these steps appear to work at least in Ubuntu 20.04. I would appreciate feedback so that perhaps it will be possible to develop a robust guide to running Scrivener on Linux.


Thanks for that.
I just successfully installed Scrivener 3 on my Linux Mint 20.3 Cinnamon following these instructions.
I’d struggled previously so ran Scrivener in a Windows 10 VirtualBox because I couldn’t be bothered messing around - didn’t need more excuses not to be writing :smirk:
Thanks for taking the time to post.

Many thanks for your reply. I am very happy that my post was useful. However I may have posted too soon. Although Scrivener works perfectly in terms of file creation editing and compilation, I am using a trial version of Scrivener and now that I have bought the license when I try to activate it, the activation fails. I get the following message:
Scriv activation failure
Reading through the forum I have noted that activation has been a problem. I am using dotnet462 but even so it will not activate. Any suggestions anyone?
Many thanks,

Sorry I can’t be of use regarding the activation.
As I said, I followed the instructions and was able to activate without problems.

Thanks anyway - I think I will post a separate thread to try and get help.
Good luck with your writing!

1 Like

Problem Solved - Use dotnet 4.7.2

I erased my Wine installation completely and did a clean install, but this time using dotnet 4.7.2. Everything else was the same as my instructions above.

Although I know very little about Wine, this suggests that the problem was simply connecting with Paddle for the 64 bit version of Scrivener. It might well be that with dotnet 4.6.2 the 32 bit version of Scrivener can be activated. With dotnet 4.7.2 there are no problems with activating the 64-bit version.

So the instructions above only need to be modified by changing step 6. to:

  1. Install dotnet472 (from a suggestion in a post by @AmberV)

    winetricks dotnet472

This gives the following message:

This package (dotnet472) may not fully work on a 64-bit installation. 32-bit prefixes may work better.

Once again I hope this helps those wanting to have a problem free installation of Scrivener on Linux.


This didn’t work for me in Pop!OS 22.04 with Wine 7.7. Not sure why, but when I installed dotnet472 it said warning: This package (dotnet45) is broken in wine-7.7. Broken since 5.18. See for more info. Use --force to try anyway.

As I mentioned in my previous post to you, it might help to use the wine installation command:
sudo apt install --install-recommends winehq-stable.
You used staging in place of stable which is probably why you got Wine 7.7. For getting Scrivener to work it is probably better to have a stable version, and then you should be able to avoid the problem of the error with dotnet. By the way when I installed dotnet472, it was a long process of installing all the intermediate dotnets with lots of warnings, so be patient. I cannot promise that this will work (I was using Ubuntu and I don’t know how different it would be on Pop!OS 22.04) but I think using Wine 7.0 is worth a try.
Good luck!

1 Like

It’s working perfectly in my Manjaro Linux!! Thanks!
Some tips:

  • If you get black notifications or totally black selected menus, just select Windows 7 instead of Windows 10 on winecfg.
  • Change all the fonts on the Scrivener Options to the same fonts of the operational system and it will look like a native Linux software, totally and perfectly integrated with your desktop. Smooth and flawless.

I also have Scrivener 3.1.1 working wonderfully well on Manjaro KDE. Up until now I have been using Windows 10 in VirtualBox. However the latest Windows Update borked my system. I spent most of yesterday trying to fix it and gave up knowing the next update may do the same damage.
Oh what a feeling to be free of Windows! :joy:

I did the following, based on @Rolando advice in OP:
(Note that some installs failed because a GPG key was missing. All I needed to do was go to the package on the repo and look at the comments. The latest comment had the GPG key, so I only had to enter that in a terminal. This happened twice during the install process.)

  1. Installed wine-stable 7.0-3
  2. Installed Winetricks
  3. Installed winetricks dotnet472. Note that this takes a long time because every dotnet from v4 onwards is d/l, and installed followed by the next version, e.g. 4, 4.5, 4.6 etc.
  4. Entered the command winecfg in a terminal and chose Windows 10
  5. Downloaded Scrivener for Windows (64-bit) from L&L
  6. Created a directory in ~/.wine/drive_c/Program Files
  7. Moved the d/l Scrivener.exe to ~/.wine/drive_c/Program Files
  8. Entered the command wine Scrivener-installer.exe in the terminal
  9. A shortcut appears on the desktop so I edited the properties to show the Scrivener logo
  10. I followed the excellent tip of @leandrobp to alter all the Scrivener fonts to those of my Manjaro installation.
  11. I entered my Scrivener licence key and it validated without a problem.

I am stunned at how responsive and satisfying Scrivener 3 is on Linux.
Happy days.

1 Like

I too have Scrivener 3.1.1 installed under Wine 7.0 (Mint 20.3). I’d upgraded from Scrivener-previous (whatever that was, 3.0.something, I think), which also worked.

Problem came when I went to compile. When I tried to edit the compile settings, Scrivener crashed. This behavior is new.

  1. Does anyone on the Scrivener team know what might have changed in their use of the Windows environment to have caused this change in behavior? If so, I can modify the Wine environment accordingly.

  2. Would someone in this sub-community — Scrivener-under-Wine users — test my results to see if they’re consistent?



I have Scriv 3.1.1, Wine 7.0, Mint 20.3, Cinnamon Ver 5.2.7, Kernel 5.4.0-122-generic.

I have no issues compiling to print, epub3, kindle or PDF. Also, no issues when changing various compile settings (ie Duplicate and Edit Format).

I tried the compiles with the interactive tutorial, my own current book and a brand new novel-format project.

Hope this helps.


Thanks. I may rebuild the Wine bottle and try again. Glad your upgrade was successful.

What are the contents of your Winetricks log? I.e., what elements are installed — dotnet, etc.?


1 Like

For what it’s worth, I almost always use wine-staging, and I haven’t had a problem with Scrivener. There are some versions of WINE that dotnet is bugged in, but that shouldn’t be a problem for later ones. winetricks is overly cautious, and can be overridden, if memory serves.

1 Like

I got everything installed correctly but for some reason when launching, Scrivener gets hung up on Loading Fonts. I’m running Manjaro. I’m not sure why it doesn’t move past the fonts. Any ideas of how I can troubleshoot this?

Just fyi. Winehq released a new version on the stable branch: 8.0.2. This breaks Scrivener back to the issue I had before on looping on loading fonts. I had to install Downgrade and downgrade it back to the 7.0 version that was stored in my cache.

On a fresh install of Scriv 3 I struck this problem of Scriv freezing on ‘loading fonts’
Solved by installing MS speech api

winetricks sapi

Thanks very much for the tip. I was a little sceptical that it would work in my case, but just tried it and was amazed to see that it did work!

I was sure that the problem was the upgrade to Wine 8. Thanks again!

1 Like

I’ve been using Wine 8 for a while now without major issues. The only thing I’ve noticed is that the logging window doesn’t come up (enabled in General: Warnings) for whatever reason. Not a huge issue though, if you need it, you can always launch it from a shell window to get that output.



I did a fresh install of Linux Mint 21.1 Mate, installed Wine 7.0, winetricks, the latest recommended dotnet472, Scrivener 3.1.4. And it works great.

Except I can’t register it!

For what it’s worth, I compiled the wine 7.0, took forever, but I learned that I could do it.

Any suggestions on how to register? I’ve never tried Linux Mint, kinda like it.

I’m currently using Crossover with MX Linux because I could never get around the font stuck issue in Ubuntu. It works okay except with a few minor glitches in the font drop-down menu.

Thanks in advance…