iOS 14 - Heads-up: No way to access non-Apple fonts in Scrivener

I have many third-party fonts that I use, and I’ve installed them by adding them to my Apps/Scrivener/Fonts folder on Dropbox. I’ve used them for years.

As of iOS /iPadOS 14, none of my third party fonts are accessible inside Scrivener. I’m running i(Pad)OS 14.0.1, Scrivener 1.2.1

What’s up?

Font apps, such as Anyfont, are insisting that Apple changed their API, and that apps which want to access non-Apple-provided fonts must use a new interface. This problem is endemic to all apps that access alien fonts. (Confirmed a problem on Ulysses and on iThoughts). In addition, Apple’s files app doesn’t allow access to any cloud service but iCloud Drive.

I’m reverting to iOS 13 until this stuff is fixed—by you and other developers, by Apple, doesn’t matter. iOS 14 is unusable for my purposes.

I know this isn’t a Dropbox forum, but . . .

You comment that ios14 Files app doesn’t allow access to cloud services other than iCloud. If I open the files app on my 2018 iPad Pro 12.9 running iOS 14.01, my Dropbox folder is still there and I can access files in it. I have also used Dropbox, from Scrivener iOS and other apps without issue in 14.01.

I have not heard about this problem elsewhere. Does Dropbox not work at all for you on iOS 14?

Thanks for your response, TBrown313! The dropbox app itself works fine, as does the Google Drive app, but I can’t access either of those services from within the Files app. Scrivener works OK as it uses the dropbox API directly; Ulysses still works OK with its external folders feature, but not if I try to access a single Dropbox file. Other tools (iThoughts, Aeon Timeline) are hosed.

And my attempt to roll back to iOS 13 bricked my phone and I’m sending it to Apple for repair :frowning: Not risking it with my iPad…

There are times when Apple’s security paranoia really ticks me off. This is one of them.

I’ll check the Dropbox forum; thanks for the hint. If you can suggest any other resources, please feel free!


I can access Dropbox through Files with no problem — I’ve just used it to install a couple of third party fonts into Scrivener, using the same method I’ve always done. (Files > Dropbox > long click on font file > Share > Scrivener.)

This is on a first generation 10.2" iPad Pro (and also on a new iPad Air 10.2"), using iOS14: don’t know if that makes a difference.

I have iThoughts and save all its files in Dropbox. iThoughts on my 2018 iPad Pro 12.9 With iOS 14.01 works without issue.

These issues are obviously very complex. Only suggestions I have you have probably already thought of:

  1. Reboot the iPad from power off.
  2. Uninstall/reinstall Scrivener.
  3. Curse loudly all those who decided to make our lives easier by developing such devices in the first place.

#3 may not work, but could make you feel better.

I often remember fondly those years in the 70’s when I wrote story after story double-spaced on my Underwood manual and hand-edited them with my favorite pen.

I am using an, to put it pretentiously, in-house font I once added with AnyFont. (No Dropbox involved here.) And I can use it in Scrivener for iOS/iPadOS. Simply because it is set as the default font. But it is not possible to pick it because it does not appear in the fonts list.

Same with 1Writer. But it works in Pages and Drafts. That seems to speak for a changed API.

I’ve enthusiastically employed remedy 3 already… :smiley:

I’ve also tried remedies 1 & 2. No joy on the fonts.

I did resolve my issues with the Files app. I deleted and re-installed both Dropbox and Google Drive, and now iThoughts and Aeon Timeline are able to access my work again.

I followed your method to import the font into Scrivener, but while I received a “successfully installed” alert, the font is still not available in the fonts list.

That confirms what I learned from the developer of Anyfont. And yes, my default font is OK but I dare not change it, One of the things I do to keep my eyes fresh is change up my writing font from time to time. Not happening right now…

I received a reply from Ulysses support, acknowledging the problem and that a fix is being tested now. How about Scrivener, L&L?

That’s odd – I’ve successfully installed three different fonts using that method: EB Garamond, ET Bembo and Bad Handwriting and they all appear in the fonts list.

If you tell me which ones you’re having difficulty with, I’ll have a go with them and see what happens, if you like.

Victor Mono, Recursive Mono Casual code, and Hack are the ones I’m using as writing fonts right now. You can find Hack and Victor Mono on, though for the very latest you’d need to track through to the websites.

I’ve just tried EB Garamond by your method, and it worked… but Victor Mono works neither in .otf nor in .ttf format. Bummer. And I don’t care about EB Garamond… I want my programmers’ coding fonts… sniffles ::put pouty face here::

Seriously though, I’m never going to compile to final product on my iPad, so what I need available are my writing fonts, which include many strange monospaced fonts like Victor Mono, Hack, RecMono Casual, Source Code Pro, etc. The closest I come to writing in a proportional font is iA Writer Duo, which isn’t very close.

Maybe EB Garamond et. al. were at one time Apple-provided fonts and therefore still have the Apple secret code in them somewhere… :smiley:

In any event, Scrivener’s preferred method of installing fonts by means of putting them in the Dropbox sync folder doesn’t work. Installing from AnyFont as a system profile doesn’t work. And it’s not just Scrivener, but bunches of apps that used to offer 3rd party font support don’t work either.

I blame Apple for this debacle, but there it is: Apple’s changed the rules, and it’s their backyard, ball, bat, and glove, so if an app wants to play, they have to work with the new rules… :imp:

Hi SD,

This is increasingly odder…

All those fonts (and others) work for me without any problems or need for workarounds and they all show up in the fonts menu.
[attachment=0]File 30-09-2020, 08 20 42.png[/attachment]

[attachment=1]File 30-09-2020, 08 16 54.png[/attachment]

[Just for completeness, the full process I use:

  1. Files > Dropbox > Fonts > download the *.ttf or *.otf file (long tap + download)
  2. Long tap on the file and choose Share
  3. In Share, find Scrivener (may need to swipe along to More…) and tap on it.
  4. Open Scrivener and the font is there.]

This is on an iPad Air 3rd Generation, using iOS 14.0 and Scrivener 1.2.1 (2096). I wonder why this works on this setup but not on yours? As I said, odd.

I’ll download 14.01 and see if that breaks it…

EDIT: No, it’s fine on 14.01. Just a thought: I don’t have AnyFont installed and I think you do. What happens if you uninstall it?

Thanks, Brookter, for your effort. I am jealous. :mrgreen:

I infer that you must share each variation (regular, italic, bold, bold-italic, etc.) separately from Dropbox to Scrivener; is that correct?

If I may ask, do you use Dropbox sync? If so, does the method of putting the fonts into a Fonts subfolder of your sync directory work for you?

Anyfont in and of itself does nothing if it’s not active. It installs fonts via system profiles (each of which I must manually approve for installation in the Settings app,) The fonts, being now part of the system, can no longer be affected by Anyfont. Deleting the app would do nothing; I must delete the system profiles to test this. It may well be that having my fonts installed as system profiles (by Anyfont) is causing my problem with using fonts installed directly into Scrivener; certainly the only font that worked for me (EB Garamond) is one I don’t have in my system. But if I remove them, I won’t be able to use them in other apps which are updating to the new API, such as Ulysses and iThoughts.

Truth be told, I’m reluctant to waste more hours on this. Installing the fonts into Scrivener via Dropbox share, four or more shares per font, is a laborious workaround for a system problem that all developers who want to provide third-party font support are going to have to deal with. There’s a new API. I’ll switch to Mac Scrivener for the duration. If L&L doesn’t update iOS Scrivener and I need to use iOS, I can always set up External Folder Sync and use some other editor on iOS—one that has switched to the new font interface.

Thanks again for all your help!

No problem, SD — I’m just as an inveterate fiddler with fonts as you are, so any chance to play is welcome. I added all of your suggested fonts (and a few more) to the desktop this morning…

Yes, you have to go through the procedure with every variant, so it’s not slick, but it’s not too bad. I’ve never tried putting the fonts in the Dropbox sync folder — the technique I described is the one I’ve always used. I’ll give it a go (but not till after the rugby has finished playing on the iPad…)

I don’t blame you for not spending too much time on it.

Brookter, do give Victor Mono a go if you like to write with monospaced fonts at all. It’s grown on me (perhaps like a fungus :smiley:) and I now use it for all my Scrivener UI as well as using it as my primary writing font. Its one fault is that if you want to print something (like index cards) its tall line height can be a problem. I use JetBrains Mono for my index card printing font…

No more hockey here in the US, and we don’t get many rugby broadcasts; I suppose I actually have to write something now… :smiley:

At the moment there’s a lot of rugby and cricket on while they catch up, so it’s difficult…

Anyway, here’s the result of test 2… I copied all the fonts to my Dropbox/Scrivener Sync/Fonts directory and they all transferred over with no problems, and with me having to do nothing at all. I wish I’d known about this method before…

Documentary evidence (include Victor Mono, of course…). This is on a different iPad from the first test, so these are new fonts for this device.

[attachment=0]File 30-09-2020, 20 03 06.png[/attachment]

Really odd that it doesn’t work for you. Wonder what the problem is? I’ve not tried it with Ulysses because Setapp have taken my subscription away…

Ah, Setapp. I simply scaled myself back to Ulysses on my iPad only (you have 2 seats for your base subscription and I decided I didn’t need Ulysses on my iPhone—iPad and Mac would do.)

I’ve still got the Setapp, but the two seats are for the MBA and iMac. I like Ulysses and would use it more, but I also like Emacs (even more configuring fun than Scrivener) and IA Writer and Multimarkdown Composer for shorter pieces. I do not suffer from a shortage of markdown writing tools; I do suffer from the inability to stop faffing about with software…

LOL! I too suffer from this crippling malady…

I couldn’t leave it alone… it’s definitely the API conflict. If I remove the fonts from the system profiles area, then the fonts in the /Dropbox/Apps/Scrivener/Fonts folder are available from the Scrivener font menu. Of course they then disappear from Pages, which evidently (and unsurprisingly) uses the new font API.

It’s no hardship to avoid Pages, but I miss having the fonts just available in Scrivener, Ulysses, Office Suite, and iThoughts. I was confused by the fact that I’d installed the fonts via both methods, but I prefer having them installed iOS-wide.