Laggy scrolling

Is anyone experiencing choppy or laggy scrolling in Scrivener documents? I’ve restarted and get the same thing happening. It’s not happening in other apps. It’s very annoying. I have to wait for the scrolling to catch up and then it often continues to try and scroll even once I get to the top of the doc. Any thoughts would be appreciated.

If using a Bluetooth mouse to scroll, does stoping/re-starting Bluetooth help?

Actually, it happens on bluetooth mouse and trackpad.

Important questions:

  1. Which version of the OS?
  2. Which version of Scrivener?

Subsidiary questions:

  1. Are you using “Scrivenings mode”?
  2. Does your project have a lot of images?
  3. Does your project have a lot of inspector comments or footnotes?

:smiley:

Mark

1 Like

MacOS Sonoma 14.2.1
Scrivener 3.3.6

As far as I can tell, I am not using “Scrivenings Mode”. At least, when I search in Help, none of the ‘scrivenings’ tools are checkmarked.
No images in the document or project.
No inspector comments or footnotes.

Thanks!

You can tell if you’re in Scrivenings mode here:

If you’re in “Single Document” mode, how long are your documents?

When did you last close Scrivener and shut down your computer?

1 Like

3,000ish words.
And I just restarted both Scrivener and the computer. Problem persists.
thanks

I’m not sure what else to recommend. I only encountered lagging (some years ago) on a translation I was editing and using inspector comments for feedback. They built up and caused scroll lagging while in Scrivenings as a lot of calculation was going on in the background.

The only other thing I can think of is resetting the Display Settings.

https://scrivener.tenderapp.com/help/kb/macos-troubleshooting/resetting-a-projects-display-settings

I’d duplicate the project first for safety.

With any luck one of the support staff will happen by soonish.

:slight_smile:
Mark

Thanks for the thoughtful responses. The display settings troubleshooting is for if it happens in a single project. I’ll wait and see if a support staff person happens by.

Thanks again,
Frank

1 Like

Uninstalled and downloaded the previous version and the problem is fixed.
Frank

2 Likes

Glad you got it fixed. But what do you mean by “previous version”?

:slight_smile:
Mark

1 Like

Downloaded version 3.3.1

3.3.1 has known compatibility issues with Sonoma, so that’s not a permanent fix.

Does it always lag, or does it sometimes freeze but otherwise behave normally? I’m asking because “freezing” is often a sign that your autosave interval is too short, and Scrivener is trying to save when you haven’t actually paused. The setting is on the Settings → General → Saving tab, if you’d like to try changing it.

1 Like

An uninstall and reinstall seems to have taken care of the problem for now. I upgraded to 3.3.6 bc of the incompatibilities folks talked about. Support got back to me and said that it is probably happening because I have my text zoomed. So, if it starts again I’ll have to figure out another way to make the text bigger for me to see.

Thanks all for your thoughtful replies.

Frank

Remember that your font and it’s size in the editor can be completely different from the font when compiled; that is at the heart of Scrivener’s design. So rather than using zoom, why not try using a bigger font size in the editor?

:slight_smile:
Mark

It’s worth noting there is also a report of the page drop shadow setting causing lag, but that report is from several years ago now and may no longer be relevant—macOS 10.15 had a number of optimisation issues in its early days, as I recall.

I’m having the exact same issue. Updated to Sonoma and it’s the only program lagging on scroll. Really quite maddening for editing long documents.

Hi Lancelot, and welcome to the forum.

When you’re scrolling and seeing the lagging in macOS Sonoma, are you working with several documents in a long Scrivenings session?

And if so, do you have the main editor zoomed in on the text past 100%?

I ask because I’ve seen a few help tickets with users reporting that combination results in lagging behavior.

I’d suggest zooming out, scrolling, and zooming back in as a test to see if that improves the behavior.

dunno what you mean by a long scrivenings session?

I have closed out several scriv files and zoomed, unzoomed. it didn’t help

Hi Lance. By a Scrivenings session, I’m referring to selecting multiple documents in the binder and then clicking the icon just to the right of the document titlebar in the toolbar. It’s the first of the three views: Scrivenings, Corkboard, and Outliner.

If you’re viewing multiple documents in a Scrivenings session or a single document that’s several thousand words in length, the lagging might be due to delays in the text being redrawn.

About how many words are you typically writing in a single document? If I remember correctly, you usually write SFF, so I’m guessing your projects are large ones. (Edited to add: You and I have chatted about writing via the WU UnCon…)