Scrivener jumps to No Style on each new Paragraph

Is there any way to remove this, so I can keep writing in the format I selected permanently, and only switch to No Style manually?

Thanks for the helo in advance!

Before going too far down that path, I would read §17.1 is the user manual PDF, to make sure we’re on the same page about what you’re intending to do. Scrivener is definitely not meant to be used like a word processor, where every paragraph is styled, and doing so can lead to scenarios like this. So if that’s what you’re looking for, the software is already encouraging you not to.

That said, there are certainly valid contexts where continuation of the current style is desirable, such as code blocks and quotations. Scroll down to §17.3.2 for the details on how styles can be set up, including which style is selected next when you press return.

1 Like

I found the workaround for what I want to do. In my notes i want one format and theyre not there to be compiled.

But my manuscipt which will be, now is written with the “no style” as a whole, but in each document inside I formatted the text to use Arial font and a single line spacing, so writing looks good to me.

Any detrement to this?

I’d recommend changing the default formatting to match this, which will give you a new “No Style.”

You can use the Project → Project Settings → Formatting pane to set the default for this project, or Scrivener → Scrivener Preferences → Editing → Formatting to set the default Scrivener-wide.

So what it sounds like to me is that you want to have a particular type of document that has it’s own default formatting, separate from what you use to write “manuscript” content as. This is something I do as well, and it sounds like you also work the way I do, keeping notes threaded right into the Draft folder itself, around the things I will be writing. If notes have a distinctive font and formatting, it is easy to keep things straight when looking at them all together in Scrivenings mode.

This is what has worked best for me over the years:

  1. Set yourself up with a document templates folder in this project. If you’ve never done that before, it’s really easy. Just make a folder anywhere in the binder (except Draft and Trash), you can call it “Templates” if you want, but it doesn’t really matter. In Project ▸ Project Settings... under Special Folders, select this folder as the “Templates Folder”, and click OK.

  2. Now whatever you put into this folder will be made available from the Project ▸ New From Template submenu—and the first entry will even get its own dedicated shortcut. They will also be easily available from the green “Add” button in the toolbar.

  3. Create a document called “New Note”, and maybe give it a special custom icon so it looks distinct (I use the Yellow Notepad icon).

  4. Type in some dummy text, like “New note…” into the main editor. Format it the way you want note text to appear. You could use a style here, but there is little need to.

  5. Lastly, select the text in the editor. Scrivener duplicates almost everything about an item when you use it as a template to create new items—including the fact that text within the editor is selected.

    Optional: for those using this tip to create notes in the Draft, you will also want to set the default state for these notes items to be excluded from compile. Click the little page icon in the lower right corner of the editor, so that the checkmark turns into an “X”.

  6. Try it. Click where you’d like to add a new note file, use the menu command, shortcut or toolbar button, and select “New Note”. Now you can see why leaving the text selected is useful, you can just start typing over the dummy text immediately—and since we saved dummy text that is formatted the way we want, that is how all text typed into this document will appear.

Now what you might want to consider is creating your own starter project template that has this set up as well, so that whenever you create a new project, you’ll have formatted notes ready to go with your preferred font.

I already have something like that worked out, and it’s fantastic. Thank you for all the kind suggestions!