Toolbar Issues

Has anyone found a fix for the toolbar moving to the right and refusing to go back?

I can reset it by going back to default and resetting, but then when I customize the toolbar, the next time I close and re-open scrivener (or open another file), it breaks again.

Oh my gosh! this happened to me other other day. I thought i had messed something up.

I am not sure what you mean. I have never had my icons shift. How are your Quick Seach and group mode placed. I kept them in their relative position and filled in icons around them. I never have had a shifting issue.

It looks like this. So search and everything has shifted to the right, and the left is empty.

Go into View >customize toolbar> main toolbar and look at where seperators are, my setup that corresponds to above toolbar I uploaded will be in two pictures. then to look at placements of gaps and seperators to see if a pattern emerges. I hope that will help you.


tool two

There are no separators there. When I first set it up, it looks perfect. but then after scrivener restarts just once, it’s all messed up. Here’s a screenshot. As you can see, View and Search is first before a separator, and there’s no gap until after “insert” - which means everything should be sitting tight to the left until the “quick search and target”

I get this all the time.
Add a bunch of gaps where you already have one.
Like 6-10 everywhere ; it’ll make it not as bad.
→ Start by adding the exact same number of gaps everywhere, so that the toolbar appearance doesn’t change. (Each gap is worth a relative % of the available empty space. )
→ Then balance the whole to your taste by adding again 1 or 2 gaps where needed.

I think the issue is that an unsolicited gap is added before the very fist icon. So, the more you add of them (reducing that unwanted gap’s width value when compared to the whole – instead of being one of say 5 gaps, it is now 1 of 25 (its share of the unoccupied space then going from 20% to 4%)) the less the toolbar becomes messed up.

See how there visually is an unwanted gap before “Back up now” (but not in the above list).
And yet, it ain’t that bad :
image
Normally, the first icon (back up now) should have been all the way to the left. But doing as I just described, it is almost where it should have been.

This may or may not temporarily “fix” the issue. See here:

There are other reports or this issue as well, one just recently but I was not able to find it for this reply. I have not had the issue and don’t remember what was done to fix it. I have always saved my preferences so maybe I have found the answer or maybe not. Whatever. Something in the order of the icons in the tool bar (?), something in what is stored in the preferences (?) or what have you is causing a spurious gap to be placed in front of your first desired icon. You may have better luck going back to the defaults and placing your icons and order how you want them, then do a save of the preferences.

That actually worked, thank you! Does it mess up again, or does this fix it “forever” in you experience?

In my experience, once you’ve done that, it is fixed for good.

1 Like

Thank you so much for the tip!

1 Like

Yeah, this is a known bug. Reported here, and also discussed here.

I get it every now and then, but haven’t seen it in a few months. If @Vincent_Vincent’s solution works for you, that’s wonderful. I am flagging @MimeticMouton on this, as maybe that will give the developers an insight into the problem.

Best,
Jim

2 Likes