3.0 doesn't autocorrect "michael" to "Michael" as I type. Searched everywhere for fix. I have fallen & failed. Hel-lep!

Tested against 2.8 and it works fine there, so it’s not my Mac’s settings.

Played with preferences; played with Edit > Spelling & Grammar. No joy. I’d have much more joy and success if I just played with myself instead –

But I wouldn’t accomplish any writing that way. And I’m prone to cramping. Help me with my frustrated typing libido. How TF do I get 3.0 to understand that it’s Michael, not michael before I start slapping 3.0 on the rump.

I don’t know why you are getting different results in different programs, as none of this has anything to do with Scrivener (maybe the difference between 32-bit and 64-bit text editing? Try in TextEdit; that should be closer to Scrivener 3’s behaviour in some regards). Auto-correct is a system level feature. Honestly I don’t know much about it as I never use it, but if it works anything like iOS, could it be it has stored “michael” as the correct spelling through some inadvertant confirmation made in the past on your part?

Meanwhile, Scrivener has auto-completion. Try adding “Michael” to the Project ▸ Project Settings… panel, under “Auto-Complete List”, and switch the “Suggest completions as you type: in script mode only” setting, in the Corrections preference pane, off.

Hi Amber

Thanks for the reply.

It not just michael. It also struggles with jeff and amanda and their holiday in spain. It struggles with james sipping coffee in paris also. And let’s not mention mary in brazil.

So i downloaded the 3.0 demo to another Mac to see if it was just my daily Mac which was playing up. But nope. Auto-correct just doesn’t work at all on 3.0. It’s like spell check is now a 3 year-old with crayons. It’s James in Paris you 3 year-old!

I’ve searched this forum, tried and tinkered and failed. I notice many other people have this exact same issue, obviously unresolved.

3.0 is 100% useless to me because of this. This is paramount to typing, a basic necessity. 100% frustration.

What I don’t understand is: Why do some people have this issue, and some others don’t? Surely you guys with all the facts should be able to solve this. This is the type of simple issue which will affect reviews, your reputation, and therefore sales.

It’s a shame, since I like many aspects of Scrivener (outlining) … but I also need to be able to type! LOL. Until spellcheck/auto-correct is resolved I’m sticking with what I’m already using, because it can handle the basics, and works without fault.

I have the same issue.

Autocorrect works to correct typos such as “whattever” to “whatever”, but it won’t correct words needing capital letters.

It does work in TextEdit, Notes, Mail, etc.

Hoping 3.0.3 resolves this, though not a major issue for me.

Have deleted and reinstalled Scrivener, without resolution.

Know about the settings in preferences and the edit menu (and in system preferences, which is why it works in other apps).

The reason for this is that Scrivener uses its own auto-capitalisation routines instead of the built-in ones that Apple uses in TextEdit etc. I am wary of moving over to Apple’s routines because a lot of uses like the ability to turn off “auto-capitalise ‘i’” separately, which is not possible with Apple’s settings. Also, if I adopt Apple’s methods, then auto-capitalisation could not be turned on separately to auto-correction - Apple’s auto-capitalisation only works if auto-correction is turned on. So there are pros and cons either way.

I have autocorrection and autocapitalisation turned on, but the autocapitalisation won’t work. Autocorrect of lowercase words does work, but it won’t transform keith, for example, to Keith.

Any other setting which might also have an impact?

Could it be be the problem (with fix) described here?

literatureandlatte.com/forum … hp?t=49881

Thanks, derick, for reading and helping.

I actually saw that thread yesterday while searching for a solution. Unfortunately, the suggested fix hasn’t worked on my Macs.

As I said in my post directly before yours, it won’t change “keith” to “Keith” because Scrivener uses its own autocapitalisation system, not the built in macOS one. It provides capitalisation for the start of sentences but not for proper nouns. The option needs to be turned on in Scrivener’s preferences, not in System Preferences.

I have updated the code for 3.0.3 so that Scrivener will use Apple’s capitalisation code if “Correct spelling automatically” is ticked in System Preferences and auto-correction is turned on in Scrivener and spell-checking is turned on in Scrivener. (Apples’ text system’s auto-caps code will not work unless all three of these conditions are met). If any of these conditions are not met and the user still has capitalisation ticked in Scrivener’s preferences, Scrivener will fall back on its own capitalisation code.

It’s a shame that Apple’s capitalisation feature is such a mess, depending on three conditions to work at all.

Many thanks, Keith.

I understood your previous post about using a bespoke autocapitalisation system in Scrivener, but I didn’t twig that it didn’t apply to proper nouns. I made an assumption (as, I think, the OP did) and followed my assumption down a rabbit hole.

Very grateful to be dragged out of the rabbit hole again, and super happy to learn of the added 3.0.3 loveliness. Going to be a very impressive release. Thanks,

Hey KB, with Scrivener (or whatever the most up-to-date 2.8 version was called) spell check, auto-correct/capitalization worked flawlessly (Mac).

2.8 was Einstein. 3.0 is dyslexic Rain Man on crack.

Upgrading is downgrading.

Thanks Derick. I’ve tried these suggestion previously, plus switching page view on/off, and nothing worked.

It’s a bug, but one which doesn’t affect everyone obviously. L & L surely know about this, and I suspect know the answer. For example, I’m running OS 10.13.5 on Macs which are 3-4 years old. Maybe it’s older Macs where this issue arises. Something like that. But it’s a bug–if not 2.8 would’ve had the same issues, which it didn’t.

Hey, KB – if you fix auto-correct with 3.03 so it works properly like it did with 2.8, then I’ll buy 3.03 (after I demo it, haha!)

There is no need to insult non-NT people just because you’re unhappy with the way one function of your software is behaving.

I agree with you. And applaud you for speaking up.

It’s called humor. Maybe you PC do-gooders, on your moral high horses with nothing constructive to do, should try it, and not take things so “literally” and seriously. Thanks for your contribution to the Scrivener conversation though – none. Interference and hijacking – plenty.

(For the record, I’m justified in speaking like this as it’s a part of MY family life, my world – so unless it’s a part of yours, then you should perhaps consider avoiding subjects where you have little knowledge. I came here to talk about Scrivener, not to feel like I have to explain myself to lost- and petty-mindedness. ).

Dang, cubem3, not only are you a comic genius, but you also make the case for intolerance, prejudice, discrimination, and bigotry so well (and with such original thinking) that you must surely be slaying moral high horses with every word you utter.

What a nonsense it all is – people doing good things, treating each other with respect, and imploring others not to cause offence.


I applaud your sincere determination and conviction in defending the moral judgment of a movie character. Though in the real world I find your contributions to be misguided, foolish and lacking, and more akin to a disconnect, a failure.

Thanks for all your help. No, seriously!

So if I understand what you are saying correctly, you have a fictional movie character in your family, in your world? :mrgreen:

Meanwhile we have but one rule on the forum here: be polite. Your original joke was pretty borderline in my opinion, but less defensible have been your personal attacks on those calling you out on that joke since then. If you can’t take criticism, don’t dish it out.

Hey, some of us are really funny. For example I just said “well those are the easier kind to make” in a meeting and everyone was in hysterics.